Arles Image Web Page Creator 7
Arles Image Explorer 7

User Manual

I

Arles Image Web Page Creator Help

Table of Contents
Part I About

1

Part II Getting Started Creating a Image Web Page
Gallery

1

Part III Order

2

Part IV Arles Image Explorer

2

1 Viewing Images
................................................................................................................................... 3
2 Rotate Images................................................................................................................................... 4
3 Sorting Images
................................................................................................................................... 4
4 Selecting Images
................................................................................................................................... 5
5 Editing Image...................................................................................................................................
Information
5
6 Editing Folder...................................................................................................................................
Information
6
7 Drag and Drop...................................................................................................................................
Images
6
8 Folder Bookmarks
................................................................................................................................... 7
9 Rename Files ................................................................................................................................... 8
10 Email Images ................................................................................................................................... 9
11 Viewing EXIF...................................................................................................................................
Info
10
12 Editing Image
...................................................................................................................................
IPTC Info
10
13 Editing JPEG...................................................................................................................................
Comment
12
14 Movies

................................................................................................................................... 13

Playing Movies
..........................................................................................................................................................
Select Movie ..........................................................................................................................................................
Poster Frame

13
13

15 Image Explorer
...................................................................................................................................
Options
14
Image Explorer
..........................................................................................................................................................
Interface
..........................................................................................................................................................
IPTC/EXIF
..........................................................................................................................................................
Images
..........................................................................................................................................................
Email
..........................................................................................................................................................

14
15
16
16
17

16 Images Database
................................................................................................................................... 18
Cleaning the database
..........................................................................................................................................................
Backing up the
..........................................................................................................................................................
database
Restoring a database
..........................................................................................................................................................
Checking and..........................................................................................................................................................
repairing the database
Export to text..........................................................................................................................................................
file
Import from text
..........................................................................................................................................................
file
Changing the..........................................................................................................................................................
database location

18
19
19
20
20
20
21

17 Keyboard Shortcuts
................................................................................................................................... 22
Image Explorer
..........................................................................................................................................................

22

Digital Dutch

Contents

II

Image Viewer..........................................................................................................................................................
IPTC Window..........................................................................................................................................................
Jpeg Comment
..........................................................................................................................................................
Window

Part V Arles Image Web Page Creator
1 Files Tab

23
25
25

25

................................................................................................................................... 26

Advanced Files
..........................................................................................................................................................
Options
File Names
.........................................................................................................................................................
Folder .........................................................................................................................................................
User Files.........................................................................................................................................................

27
27
28
30

2 Thumbnails Tab
................................................................................................................................... 31
Advanced Thumbnail
..........................................................................................................................................................
Options
Crop to fit
..........................................................................................................................................................

32
33

3 Images Tab ................................................................................................................................... 33
Advanced Image
..........................................................................................................................................................
Options

34

4 Index Page Tab
................................................................................................................................... 35
Gallery Style Options
..........................................................................................................................................................
Navigation Options
..........................................................................................................................................................
HTML Design..........................................................................................................................................................
Options
Advanced Index
..........................................................................................................................................................
Page Options
General .........................................................................................................................................................
Table
.........................................................................................................................................................
Borders .........................................................................................................................................................
Thumbnail.........................................................................................................................................................
Thumbnail.........................................................................................................................................................
Links
Popups .........................................................................................................................................................
Other
.........................................................................................................................................................

36
37
40
40
41
42
42
43
44
45
46

5 Image Pages...................................................................................................................................
Tab
46
Slideshow Options
..........................................................................................................................................................
Advanced Image
..........................................................................................................................................................
Pages Options
General Tab
.........................................................................................................................................................
Image Links
.........................................................................................................................................................
Tab
Movies Tab
.........................................................................................................................................................
Effects .........................................................................................................................................................
Other Tab.........................................................................................................................................................

6 Titles Tab

46
47
48
49
49
50
50

................................................................................................................................... 50

Advanced Title
..........................................................................................................................................................
Options
Font and Style
..........................................................................................................................................................
Options
Image Title Tags
..........................................................................................................................................................
Folder Title Tags
..........................................................................................................................................................

51
52
53
53

7 Publish Files................................................................................................................................... 54
Publish Location
..........................................................................................................................................................
Publish Options
..........................................................................................................................................................

56
57

8 Image Effects
................................................................................................................................... 57
Text labels ..........................................................................................................................................................
Logos
..........................................................................................................................................................
Borders
..........................................................................................................................................................
Image Overlays
..........................................................................................................................................................
Masks
..........................................................................................................................................................

59
60
61
62
62

9 HTML templates
................................................................................................................................... 63
Digital Dutch

II

III

Arles Image Web Page Creator Help
Simple HTML..........................................................................................................................................................
Templates
Advanced HTML
..........................................................................................................................................................
Templates
HTML Template
..........................................................................................................................................................
Tags
Simple HTML..........................................................................................................................................................
Template Example

10 Options

................................................................................................................................... 69

General
..........................................................................................................................................................
HTML
..........................................................................................................................................................
File locations..........................................................................................................................................................
Confirmations..........................................................................................................................................................
Browsers
..........................................................................................................................................................
Other
..........................................................................................................................................................

11 Other

64
64
64
69

70
70
71
72
72
73

................................................................................................................................... 73

Internet Explorer
..........................................................................................................................................................
Security Warning
JPEG or PNG?
..........................................................................................................................................................
Image Resize..........................................................................................................................................................
Methods
Image Filters ..........................................................................................................................................................
Style Files ..........................................................................................................................................................
Command Line
..........................................................................................................................................................
Run Options
Command Line
..........................................................................................................................................................
Processing

73
74
75
75
76
77
77

12 Multi-folder Processing
................................................................................................................................... 79

Part VI FAQ

80

1 How to add titles
...................................................................................................................................
to my images?
80
2 How to create
...................................................................................................................................
galleries of web pages?
80
3 How to create
...................................................................................................................................
multi-folder galleries?
81
4 How to create
...................................................................................................................................
a gallery with movies?
81
5 Copy or move
...................................................................................................................................
my images files without losing image titles?
82
6 Remove the "Generated
...................................................................................................................................
With Arles Image Web Page Creator" links?
82

Index

83

Digital Dutch

About

1

1

About
With Arles you can quickly and easily create image galleries on the web. Arles creates high quality 75
thumbnail images, modifies your images and generates HTML pages. The fully featured Arles Image
Explorer 2 is included.
Arles Image Explorer 2
Organize your images and movies.
Arles Image Web Page Creator 25
Create image web page galleries.
Getting started creating web image galleries 1
Getting started tutorial on how to create an image web page gallery.

2

Getting Started Creating a Image Web Page Gallery
If you started up with the Arles Image Explorer
the Arles Web Page Creator window 25 .

Create a gallery
1. Organize your images
Digital Dutch
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, click the Web Pages button on the toolbar to open
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Click the Browse button to view, sort and select images in the Arles Image Explorer

2

.

2. Select folder with images
Select the Source folder where the images are stored for which you want to create a gallery (eg
C:\Images\Holiday).
3. Select target folder
Select the Target folder where you want Arles to save the generated gallery files.
4. Generate gallery
Click the All button on the toolbar to generate the gallery.
5. Show gallery
Click the Show button on the toolbar to show the generated gallery in your browser.

Customize your gallery
To customize the layout of your gallery, just try any option and click the All and Show buttons again.
To get help, press F1 or click the Help button in any window.
For example, to change increase the size of the thumbnails to 120x120:
1.
2.
3.
4.

In the main window select the thumbnails tab 31 .
Set the Width and Height to 120.
Recreate your gallery by clicking the All button.
Click the Show button to view the gallery.

Publish the gallery to your web server
If you are satisfied with the results, upload the gallery

3

54

to your web server.

Order
Direct order link
http://www.digitaldutch.com/arles/order.htm
Website
http://www.digitaldutch.com
Support
Arles online support forum
Email
info@digitaldutch.com

4

Arles Image Explorer
The Arles Image Explorer is a full featured image manager. You can view, sort and rename images.
Or you can provide titles for all your images. If you started with the Arles Image Web Page Creator 25 ,
click the Browse button the open the Image Explorer.
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Viewing images 3
View images in the thumbnail viewer or full screen.
Rotate images 4
Rotate images quickly without modifying them.
Sorting images 4
Sort the images in the order you want them.
Selecting images 5
Select images to include in your galleries.
Editing image information
Add titles to all your images.

5

Editing folder information
Set folder options.

6

Drag and drop images 6
Sort your images with the mouse.
Folder Bookmarks 7
Create and use folder bookmarks.
Rename files 8
Rename your image files.
Email images 9
Email images to your friends and family.
Movies 13
Viewing movies and selecting a movie poster frame.
View image EXIF information 10
View information added to the images by your digital camera.
View and edit IPTC image information 10
Store titles, keywords and other information in your image files.

4.1

Viewing Images
Select any folder in the treeview on the left to view its images.

Layouts
You can view images in the Grid or Thumbnail layout. Click the Layout button on the toolbar to
switch between the two views. For folders with many images on when you are on a slower computer,
you may want to use the grid view. The size of the thumbnails can be changed by selecting the View
menu > Thumbnail Size.

Image viewer
To view images in the image viewer, click the Viewer button in the toolbar or double click the image.
Digital Dutch
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Rotate Images
To rotate images:
1.
2.

Select the images you want to rotate in the Arles Image Explorer 2 .
Click the Rotate button in the toolbar or select the Image menu > Rotate > Right.

How image rotation works
Arles Image Web Page Creator does not modify your image files like most other image editing
applications do. Those other applications rotate the image and then resave it, which often results in
image quality degradation.
Arles leaves the image unchanged and instead remembers how much each image must be rotated,
thus making sure the image quality is 100% maintained.
Another advantage of this method is that rotating images in Arles is lightning fast. You can rotate
multiple images at the same time by selecting them and clicking the Rotate button.
Arles' rotation method makes viewing and processing images a little bit slower, because the images
have to be rotated on the fly. If you don't want to take advantage of the Arles rotation feature, just
rotate the original image in your favorite image editing application instead.
Tip
Use Reset from the Rotate menu to show the image again in it's original position.

EXIF rotation
Many digital cameras add the orientation at which is picture is taken to EXIF information 10 that is
embedded in the photo. Arles automatically rotates images to the upright position on basis of this
information.
Sometimes the EXIF position field is not set correctly. This may happen with images from older digital
cameras that do not have a position sensor. And sometimes other applications rotate images without
updating the info in the EXIF position field.
Arles can automatically fix the EXIF position field in these images. When you rotate images that
contains a EXIF position field, Arles will ask you if you want the EXIF information to be updated. If you
select Yes, one byte in the EXIF segment of the photo file will be changed. The image quality is fully
maintained.
You can set the EXIF options in the Image Explorer Options window

4.3

14

.

Sorting Images
Sort images
By default all images are sorted by name. To change the sort type select the View menu > Arrange
Images > by Size. In the grid view 3 you also can click on column headings to sort on the column.
Click twice to sort in reverse order.
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Custom sorting
Drag and drop images with your mouse to sort them in a custom order. All sorting information will be
automatically stored in the Images Database 18 .

4.4

Selecting Images
Check the image checkbox to include or exclude images for the galleries. You can select multiple
images by holding the Ctrl or Shift keys.

4.5

Editing Image Information
Edit image titles
To add a title to an image:
1.
2.

In the Arles Image Explorer 2 select any image.
Enter your title in the Title 1 field on the Image Info panel. If the Image Info panel is not visible,
click the Image Info button in the toolbar.

You can use the Alt+Left and Alt+Right keys to browse through all images without taking your hands of
the keyboard (More shortcuts 22 ).

Insert title tags
Title tags 51 are usually used in the Advanced Title Options window, but you can also use them in the
Arles Image Explorer title fields.
To add a title tag:
1.
2.
3.

In the Image Explorer make sure the Image Information panel is visible. Click the Image Info
button in the toolbar if it is hidden.
Right click in the Title 1 field.
From the popup menu select Insert > File name.

Add image titles to a gallery
Titles defined in the Arles Image Explorer can be used in your image galleries by selecting Title1 or
Title2 on the Titles tab 50 in the main window.
To use the Title 1 field as thumbnail title:
1.
2.
3.

In the main window select the Titles tab.
Set the Thumbnail title to Image title 1.
Recreate your gallery by clicking the All or HTML button in the main window.

To use the Title 1 in any other title:
Digital Dutch
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1.
2.
3.
4.
5.

In the main window select the Titles tab.
Click the Advanced button.
In the Advanced Title Options window select a title (eg Image title).
From the Tags section select File title 1.
Recreate your gallery by clicking the All or HTML button in the main window.

Image link
The image link field can be used to add an Internet link. You can set custom links for thumbnails and
images on the Advanced Index Page Options 40 and Advanced Image Pages Options 47 windows.

4.6

Editing Folder Information
You can edit folder information on the Folder Info panel. If the Folder Info panel is not visible, click the
Folder Info button in the toolbar.

Sort folder
To sort the subfolders select a sorting type from the Sort drop down box. You can also sort folders
manually 4 by dragging with your mouse.

Edit folder title
To add a folder title:
1.
2.
3.

In the Arles Image Explorer 2 select any folder in the treeview on the left.
If the Folder Info panel is not visible, click the Folder Info button in the toolbar.
Enter your title in the Folder title field on the Folder Info panel.

Select a default image for multi-folder processing
Multi-folder processing 79 allows you to create galleries with sub-folders. For the subfolder thumbnail
Arles selects by default the first image from that folder. You can use any image instead by selecting it
as Default Image. It does not even have to be in the folder you are working on.

Select a custom style for multi-folder processing
When multi-folder processing 79 all folder are generated with the default style. To select a custom
style for a folder, select a Arles *.alo style file or standard *.arl file in the Custom Style box.
Note
You can use the Alt+Ctrl+Up, Alt+Ctrl+Down, Alt+Ctrl+Left and Alt+Ctrl+Right keys to browse through
all folders without taking your hands of the keyboard (More shortcuts 22 ).

4.7

Drag and Drop Images
Drag and drop can be used to sort
application that supports file drags.

4

, copy or move images. You can also drag images to any other
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To move or copy images
1.
2.
3.

Select a folder in the Arles Image Explorer.
Select all images you want to copy.
Drag them to another folder in the treeview on the left.

Hold the Control key while dragging to always copy the dragged images. Hold the Shift key while
dragging to always move images. Image title information will be lost if you move or copy images in the
Windows File Explorer. To keep image information copy/move your images within the Arles Image
Explorer.

Drag to another application
You can drag and drop (or copy and paste) images directly to and from the Windows Explorer or any
other application accepting file drags.
1.
2.

In the Arles Image Explorer select the images you want to drag.
With your mouse left click the images and drag them to another application, like Photoshop.

Drag and drop browser links into Arles
Arles can show images and even create galleries of webpages
(URLs). To create a folder with Internet links:
1.
2.
3.
4.

4.8

80

and even Internet addresses

Open the Arles Image Explorer 2 and select a folder where you want to store web links (URLs).
Drag and Drop any URL from your web browser into Arles. You can do this by dragging the icon in
the web browser address bar or by dragging any link in your browser to the Arles Image Explorer.
If you are connected to the Internet, Arles will automatically download the web page and create an
thumbnail.
The link field in the Arles Image Explorer Image Info panel will automatically be set to the link.

Folder Bookmarks
Arles allows you to create bookmarks for folders that you often access. Folder bookmarks work just
like browser bookmarks. Clicking it opens the folder without having to search for it in the folder
treeview.
Show/Hide the bookmark panel
To show or hide the Folder Bookmarks panel select the View menu > Panels > Folder Bookmarks.
You can also use the Ctrl+B keyboard shortcut 22 .

Bookmark actions
Create a bookmark
To create a bookmark, select the folder and then click the Add button on the Folder Bookmarks panel
header or you can select the File menu > Bookmark Current Folder. But you can also use the Ctrl+D
keyboard shortcut.
Delete a bookmark
Digital Dutch
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To delete a bookmark, select it and click the Delete key. Alternatively right click the bookmark and
select Delete from the popup menu.
Rename a bookmark
To rename a bookmark right click it and select Rename from the popup menu or use the F2 keyboard
shortcut.
Sort bookmarks
To sort the current bookmarks level right click a bookmark and select Sort Level by Name.
Move bookmarks
To move a bookmark drag and drop it with your mouse to a new location.

Categories
Arles allows you to create unlimited bookmark categories with as many sublevels as you like.
Create a category
To create a new category right click the bookmark panel and select New Category.
You can delete, rename and move categories in the same way as bookmarks.

4.9

Rename Files
Rename a single file
To rename a single file:
1.
2.
3.

Select the file in the Arles Image Explorer.
Select the File menu > Rename or select Rename from the right click menu.
Type the new name and click Return.

Rename multiple files
To rename multiple files:
1.
2.
3.
4.

Select the Tools menu > Rename Files.
In the Rename Files window, select the Simple tab.
Type a new name. The example area will show the new file names.
Click OK.

Advanced options
The Advanced tab allows you to:
· Use special tags, like EXIF fields or the file modification date, in the filenames.
· Replace or delete text in the filenames.
· Convert filenames to lower or title case.
Using file name tags
Filename tags allow you to insert special file information, like EXIF fields or the file modification date, in
Digital Dutch
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the new filename. Click the Insert Tag button to insert a filename tag.
Tag name
Filename
Extension
Folder name
File date
Counter
Counter (Advanced)
Today's date
Arles Title 1
Arles Title 2
Arles Link
EXIF
IPTC
JPEG Comment

Description
File name without extension.
File extension (eg "JPG")
Folder name
File modified date/time
Counter with automatic amount of leading zeros.
Counter that allows you specify the start value and the number of leading
zeros.
Today's date
Arles Title 1 field as shown in the Arles Image Explorer.
Arles Title 2 field as shown in the Arles Image Explorer.
Arles Link field as shown in the Arles Image Explorer.
EXIF field. Select a field from the EXIF field selection window.
IPTC field. Select a field from the IPTC field selection window.
JPEG comment

Date and time format
If you select a date or time field, like the File date or the EXIF DateTime, the date/time formatting
window will be shown. There are a wide range of date and time formatting options available.
Delete text
To delete part of the old file name type the text you want to be removed in the Delete box on the
Advanced tab.
Replace text
To replace the text in file names: Enter the text to be replaced in the Replace box and the
replacement text in the With box.

4.10

Email Images
Arles allows you send your images by email. Large images can be automatically resized to prevent
very large email messages.

Select images
To add images to the email window select them in the Image Explorer and click the Email button or
drag and drop them from the Image Explorer to the Email Images window.

Remove images
To remove images from the Email Images window, select them and press the Delete key.

Select image size
Digital Dutch

10

Arles Image Web Page Creator Help

Select a maximum image size if you want Arles to reduce the image sizes. This is handy if you don't
want to send very large email messages that can take a long time to upload and download. The
estimated total email size is shown below image size box.

Options
By default images are sent with the default Windows email application. Click the Options button to
change the way 17 you want to send your emails.

4.11

Viewing EXIF Info
What is EXIF?
Most images taken with digital cameras contain a EXIF (Exchangeable Image File Format) section. In
this section data like the date and time the picture was taken, shutter speed and exposure time is
stored.

View EXIF information
To view EXIF information select an image in the Arles Image Explorer and select Image menu > EXIF
Information or right click any image and select from the popup menu the Info menu > EXIF.

4.12

Editing Image IPTC Info
What is IPTC?
IPTC image information allows you to store information like titles, keywords, creation date in your
image files. It is a world wide standard supported by many other image editing and managing
applications like Adobe Photoshop.
Arles supports IPTC for JPEG and TIFF image files.

Why should I use it?
By storing captions and keywords in your images you can easily share image information with other
applications and you can easily move to other computers or email them without loosing title
information.
Does the JPEG image quality degrade when saving IPTC information?
No. Image quality is fully maintained. Arles only modifies the IPTC information section in a JPEG or
TIFF file when saving IPTC changes.

Edit IPTC information
To edit IPTC information:
1.
2.

Select an image in the Arles Image Explorer.
Select Image menu > IPTC Information.

Digital Dutch
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Note
You can use the Alt+Left and Alt+Right keys to browse through all images without taking your hands of
the keyboard.

Edit IPTC information for multiple images
To edit IPTC information for multiple images:
1.
2.

Select multiple images in the Arles Image Explorer.
Select Image menu > IPTC Information.

Only the fields with selected checkboxes will be modified.

IPTC Templates
IPTC Templates are an easy way to quickly fill or modify IPTC fields. For example, you can save your
copyright information in a template and load it with one click each time you want to add it to a range of
images.
To apply first click the Templates button in the IPTC image information window. Next select an item
from the templates box and click Load.

Template load options
Clear current IPTC info
Clears the current IPTC information before loading the new template. Unselect this option if you only
want to add new fields to the current IPTC contents.
Add keywords instead of replace
Any keywords in the template will be added to the current keywords. If you don't select this option all
current keywords will be cleared.
Add sup. categories instead of replace
Any supplemental categories in the template will be added to the current categories. If you don't select
this option all current supplemental categories will be cleared.
To create a new template:
1.
2.
3.

Set the IPTC fields.
Select the correct Load options
Click the Save button.

To delete a template:
1.
2.

Select the template.
Click the Delete button.

Add IPTC information to a gallery
To set the IPTC caption field as thumbnail title in a gallery:
1.
Digital Dutch
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2.
3.

Set the thumbnail title to Image IPTC caption.
Recreate your gallery by clicking the All or HTML button in the main window.

To show all IPTC information in the thumbnail title:
1.
2.
3.

In the main window select the Titles tab.
Set the thumbnail title to Image IPTC information.
Recreate your gallery by clicking the All or HTML button in the main window.

To add any IPTC field to a gallery:
1.
2.
3.
4.
5.
6.

4.13

In the main window select the Titles tab.
Click the Advanced button.
In the Advanced Title Options window select (eg Thumbnail title).
From the Tags section select Image IPTC tag.
In the tag <ImageIPTC Tag="Caption"> replace Caption with an other IPTC field name like
Headline.
Recreate your gallery by clicking the All or HTML button in the main window.

Editing JPEG Comment
What is a JPEG comment?
JPEG images can contain a comment section inside the image file. It allows you to store up to 65534
characters of text inside the JPEG file.

Edit the JPEG comment
To edit the JPEG comment section:
1.
2.

Select a JPEG image in the Arles Image Explorer.
Select Image menu > JPEG comment.

Note
You can use the Alt+Left and Alt+Right keys to browse through your images without taking your hands
of the keyboard.

Edit JPEG comments for multiple images
To edit the JPEG comment section for multiple images:
1.
2.

Select multiple images in the Arles Image Explorer.
Select Image menu > JPEG comment.

Changes will only be saved to the multiple images if the Save changes checkbox is selected.

Add JPEG comments to a gallery
Digital Dutch
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To add JPEG comments to the thumbnail or any other title in a gallery:
1.
2.
3.
4.
5.

4.14

In the main window select the Titles tab.
Click the Advanced button.
In the Advanced Title Options window select Thumbnail title.
From the Tags section select Image JPEG comment.
Recreate your gallery by clicking the All or HTML button in the main window.

Movies
In the Arles Image Explorer

2

· Play movies 13 and
· Select movie poster frames

you can:

13

.

See also:
· FAQ: How to create a gallery with movies

81

4.14.1 Playing Movies
To play a movie:
· Select the movie in the Arles Image Explorer 2 .
· Open the Arles Image Viewer.
· Click the Play Movie button in the center of the image.
See also:
· FAQ: How to create a gallery with movies
· Selecting a movie poster frame 13 .

81

.

4.14.2 Select Movie Poster Frame
What is a poster frame?
The default image of a movie that is shown in the thumbnail view is called the poster frame. Most other
applications show the first frame of the movie as poster frame. This is generally a bad choice, because
it is often black. This is why Arles by default selects the frame at 10% of the full play time as poster
frame. You can select any other frame as poster frame.
The Select Movie Frame window is used to select poster frames for movies. The poster frame is
used in the thumbnail viewer and as thumbnail in any generated galleries.

Open the Select Movie Frame window
To open the Select Movie Frame window:
Digital Dutch
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· Select the movie in the Image Explorer.
· Select the File menu > Select Movie Poster Frame or right click the Select Movie Poster Frame
item from the popup menu.

Select a poster frame
To select a poster frame just pause the movie on the frame you want and click the OK button.

Keyboard and mouse shortcuts

4.15

Shortcut

Action

Left Arrow

Go one frame back

Page Up

Go one second back

Page Down

Go one second forward

Right Arrow

Go one frame forward

Spacebar or
Mouse Click

Pause/Play movie

Drag Progress Indicator

Quick search

Image Explorer Options
In the Image Explorer select the Tools menu > Options to display the Image Explorer Options
window. The options are automatically saved when you close Arles.

Image Explorer Options
Image Explorer 14
Set general Image Explorer options.
Interface 15
Set Image Explorer interface options.
IPTC/EXIF 16
Set embedded information options like EXIF, IPTC and JPEG Comment.
Images 16
Set image files options.
Email 17
Set email images options.

4.15.1 Image Explorer
Thumbnails
Width and Height
Digital Dutch
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Set the width and height of the thumbnails in the Arles Image Explorer thumbnail layout.
High quality thumbnails
Select to make the thumbnails in the Arles Image Explorer look better.
These settings have no influence on the quality of the thumbnails and images generated with the Arles
Image Web Page Creator 25 .

Double click action
Select what you want Arles Image Web Page Creator to do when you double click an image.
Option
Edit with External Editor
Windows "Open"
Image Viewer

Description
Opens the Image in the external image editor.
Opens the Image in the default application. This
action is exact to double clicking an image in the
Windows Explorer.
Shown the image in the Image Viewer.

External image editor
External image editor application. In the Image Explorer you can select files and open them in the
image editor specified here by selecting File menu > Edit.

4.15.2 Interface
Confirmations
Warn when saving titles to multiple images
Switch on if you want to be warned when you are saving title changes for multiple images.

Interface
Show image hints
Select to show a tooltip with image information whenever you move your mouse over an thumbnail or
grid item in the Arles Image Explorer.
Show help panel in Email Images window
The Email Images window contains a help panel which tells you how to add and remove images.
Select this option to show it.

Arles Startup
Start with
Determines with what window Arles will startup
Image Explorer
Web Page Creator
Remember last open window

Digital Dutch
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Start with Arles Image Web Page Creator window.
Arles remembers the last window you closed and
reopens it when you start a new Arles session.
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4.15.3 IPTC/EXIF
IPTC 10 , EXIF 10 and JPEG comments 12 all allow storing information about the image in the file
itself. IPTC is often used for descriptions and keywords while EXIF information is generally added by
digital cameras and contains info about the picture, like time taken, shutterspeed, aperture, etc.

IPTC information
Confirm saving IPTC information
Shows a confirmation dialog when saving IPTC changes.
Update file modification time when editing IPTC information
Updates the file modification time when saving IPTC changes.

EXIF information
Auto-rotate using EXIF orientation field
Many digital cameras leave save the orientation at which the picture is taken (e.g. normal, 90° rotated
clockwise) in the EXIF segment. With auto-rotate selected Arles will automatically show images with
the orientation field set in the correct position.
Note: If you change this option the rotation of all images containing EXIF information will be reset.
Update EXIF orientation field when rotating
Some digital cameras do not set the EXIF orientation field and in other situations 3rd party applications
fail to update the EXIF field when rotating an image. This both results in the EXIF orientation field
containing incorrect information. Arles can fix this automatically for you every time you rotate an image.
This correction only changes the orientation field in the EXIF segment of the image file (1 byte). The
image quality is 100% maintained.
Confirm saving EXIF information
Shows a confirmation dialog when saving EXIF changes.
Update file modification time when saving the EXIF information
Updates the file modification time when saving EXIF changes.

Jpeg comments
Confirm saving JPEG comments
Shows a confirmation dialog when saving JPEG comment changes.
Update file modification time when editing Jpeg comment
Updates the file modification time when saving JPEG comment changes.

4.15.4 Images

Image types to process
Check the image file types you want to be processed by Arles Image Web Page Creator. Only
selected image types will be shown in the Arles Image Explorer 2 .
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JPEG load/save method
Select Hardware accelerated for the fastest loading JPEGs. Sometimes hardware or old drivers cause
JPEG images not to load correctly. Selecting the Standard setting might correct such problems.

HTML image load options
Arles can create images of HTML pages

80

(*.html files) and websites

80

(*.url files).

The width and height are the size of the virtual browser window used to create the HTML and URL
images.
Width

Virtual browser window width used to create the HTML images.

Min height

Recommended value: 800 pixels
Minimum virtual browser height. The generated HTML image will be at
least this height even if the HTML page is shorter.
Recommended value: 800 pixels

Max height

Maximum virtual browser page height. Web pages that are longer than
this value will be cut off. Make the max height a small value (e.g. 600
pixels) if you only want to show the top part of long pages. Select a large
value (e.g. 2,000 pixels) if you want to show the complete web page.
Be careful when specifying large values, like 5,000 or more pixels. Very
large images will be generated for long web pages. This will slow down
Arles, and might in some cases even crash older computers running
Windows 95/98/ME. Only select a value of more than a 1,000 pixels if you
have a modern computer running Windows 2000, XP or better.
Recommended value: 800 - 2000 pixels.

Website load timeout

Creating images of websites 80 can take a long time if the site's web
server is slow or if you have a slow Internet connection. When loading
takes longer than the timeout value, the image is generated even if the
page has not been completely loaded. If you are on a slow modem
connection you might want to increase this value to 60 seconds or longer.
Recommended value: 30 seconds

4.15.5 Email
You can email images from the Image Explorer. You can specify here how you want to email those
images.

Email method
Emails can be send using three different methods.
Default Windows email program (MAPI)
Emails will be sent using the default Windows email application (eg Outlook Express). Arles will
prepare the images and automatically open the default Windows email application. You can then type
your email message text in your default email application.
Digital Dutch
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Default Windows email program, Compose in Arles (MAPI)
Emails will be sent using the default Windows email application. The difference with the first option is
that you can now compose the message in Arles.
External email server (SMTP)
The emails will be sent using an external SMTP email server. The message will be composed in Arles.

Email
Your name
When you send messages this name will show up in the From field.
Your email address
This is the email address people should respond to when sending you an email. The email address
should be in the format yourname@yourdomain.com. For example jane@hotmail.com.

Outgoing mail server (SMTP)
SMTP server name
Specifies the SMTP server used for sending your email messages. Ask your Internet Service provider
or your system administrator if you don't know what to put here.
My server required authentication
Select this option if your SMTP servers requires you to specify a password.
Account name
The name you use to login into your SMTP server.
Password
The password used to login into your SMTP server.

4.16

Images Database
All image information edited in the Arles Image Explorer, like titles, image rotation and sorting order, is
automatically stored in the Arles images database.
Cleaning the database

18

Backing up the database
Restoring a database

19

19

Checking and repairing the database
Export data to text file

20

20

Import data from text file

20

4.16.1 Cleaning the database
Cleaning the database will reduce the database size. You can select the information you want to be
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removed when cleaning the database.
To clean the database:
1.
2.

In the Arles Image Explorer select Database menu > Clean....
In the Database Clean window click the Clean button.

The current database size is indicated at the top.
To clear all cached thumbnail images:
1.
2.

In the Arles Image Explorer select Database menu > Clean....
In the Database Clean window click the Clear All Cache button.

Clean Options
Remove entries pointing to non existing images
Information for image files that no longer exist on your computer will be removed.
Remove cached thumbnails not used for 8 days
Arles caches thumbnail images to speed up showing images in the Arles Image Explorer. Thumbnail
cache that has not been accessed for the specified amount of days will be removed.
Cache image explorer thumbnail images
Arles caches thumbnails to speed up showing images. Uncheck this option if you do not want to cache
thumbnails. Be warned that the thumbnail view will be much slower. Press the Clear All Cache button
to actually remove all thumbnail images from the database.
Warn if database grows larger than 50 MB
Select this option if you want Arles to warn you on program exit when the database size has grown
larger than the specified amount of mega bytes.

4.16.2 Backing up the database
To backup your database:
1.
2.
3.

In the Arles Image Explorer select Database menu > Backup.
Specify a backup file name.
Click OK.

4.16.3 Restoring a database
To restore a Arles images database:
1.
2.
3.
4.
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In the Arles Image Explorer select Database menu > Restore.
Select a Arles database backup file.
Click OK.
Confirm that you want to overwrite the current database.
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4.16.4 Checking and repairing the database
To check your database integrity and repair any possible problems:
1.

In the Arles Image Explorer select Database menu > Administration > Check and Repair.

4.16.5 Export to text file
All data edited in the Image Explorer is stored in the Arles database. This data can be exported to a
text file by using the Export Database Data wizard.
To export data from the Arles database:
1.
2.
3.

In the Arles Image Explorer select Database menu > Administration > Export to Text File.
Follow the instructions of the Export wizard.
Click Finish.

Wizard options
Step 1: What do you want to export?
Select Images data if you want to export image titles and other image information. Select Folders
data if you want to export folder titles.
Database Export options
You can export all data or only the data for a folder.

Step 2: Select fields to export
Select the checkbox for all fields you want to export. If you want to import data into the database later,
make sure the Filename field is selected. This field is required for the database import 20 .

Step 3: Specify export file name
Specify the file name of the export file.
Field delimiter
This is the character that will be added between all fields.
Text delimiter
Text fields will be enclosed in this character.
When you are satisfied with the results, click the Finish button to start the export process.

4.16.6 Import from text file
To import data into the Arles database:
1.
2.
3.

In the Arles Image Explorer select Database menu > Administration > Import from Text File.
Follow the instructions of the Database Import wizard.
Click Finish.
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Wizard options

Step 1: What do you want to import?
Select Images data if you want to import image titles and other image information. Select Folders
data if you want to import folder titles.

Step 2: Select import file
Select the import file.
Field delimiter
Delimiter between the import fields.
Text delimiter
Text fields are enclosed in this character.

Step 3: Select column types and records
The grid will show the data from import file. If all data is shown in the first column, you probably
selected the wrong field delimiter. In that case click the Back button and select the correct field
delimiter.
Start from row
Indicates at which row the data starts. If the first column contains the field name select Start from row
1.
Select columns
For each column select the field from the drop down boxes. You should at least select a Filename
column. Without a filename Arles does not know
Select rows
Select the checkbox for each data row that you want to import.
When you are satisfied with the results, click the Finish button to start the import process.

4.16.7 Changing the database location
To change the location of the Arles Images Database:
1.

In the Arles Image Explorer select Database menu > Administration > Change Location.

Note
The database folder needs have read and write permissions for all users.
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Keyboard Shortcuts
Image Explorer shortcuts
Image Viewer shortcuts

23

IPTC Window shortcuts

25

JPEG window shortcuts

22

25

4.17.1 Image Explorer
The following shortcuts can be used in the Image Explorer window.
Shortcut

Action

Ctrl + A

Select all images

Ctrl + B

Show/Hide Folder Bookmarks

Ctrl + D

Bookmark

Ctrl + E

Show image EXIF information

Ctrl + I

Show image IPTC information

Ctrl + J

Show JPEG comment window

Ctrl + K

Select Filter box

Ctrl + M

Mark image checkbox

Ctrl + N

Unmark image checkbox

Ctrl + L or [

Rotate image 90° left

Ctrl + P

Show/Hide image preview panel

Ctrl + R or ]

Rotate image 90° right

Ctrl + U

Select parent folder (Go one level up)

Ctrl + W

Close window

Left or Up

Select previous image

Right or Down

Select next image

Home

Select first image

End

Select last image

PageUp

Scroll one page up

PageDown

Scroll one page down

Delete

Delete image

Return

Execute default action

F1

Show help

F2

Rename file

F3

Open Web Page Creator window

F4

Show/Hide subfolders

7

7

panel

current folder
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F5

Refresh view

F6

Rename files tool

F7

Define thumbnail and image crop areas

F8

Email image

F10

Take screenshot

F11

Toggle between full-screen and normal window.

F12

Show image in viewer

Mouse click

Select image

Ctrl + Mouse click

Add image to selection

Shift + Mouse click

Select range of image. The selection starts at the focused item, which
is marked by a dotted rectangle around the filename.

Shift + Ctrl + Mouse click

Add range of images to the selection.

Mouse Drag and Drop

Sort images or folders manually

Mouse wheel

Scroll one row

Ctrl + Mouse wheel

Scroll one page

Shift + Mouse wheel

Select next/previous image

Alt + Left or
Alt + Down or
Alt + PageDown

Select previous image. Works also when editing titles.

Alt + Right or
Alt + Up or
Alt + PageUp

Select next image. Works also when editing titles.

Alt + Home

Select first image. Works also when editing titles.

Alt + End

Select last image. Works also when editing titles.

Ctrl + Alt + Up

Select the previous folder in the folders treeview

Ctrl + Alt + Down

Select the next folder in the folders treeview

Ctrl + Alt + Right

Expand the current folder in the folders treeview

Ctrl + Alt + Left

Collapse the current folder in the folders treeview

4.17.2 Image Viewer
The following shortcuts can be used in the Image Viewer window.

Keyboard shortcuts
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Shortcut

Action

0 or
Numpad * or
*

Zoom to fit.

1 or
Numpad / or
/

Zoom 100%.

24
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2

Zoom 200%.

3

Zoom 300%.

4

Zoom 400%.

5

Zoom 50%.

+ or
Numpad + or
Ctrl + Left mouse

Zoom in.

- or
Numpad Alt + Left mouse

Zoom out.

Del

Delete image file.

Esc or
Ctrl + W

Close window.

F10

Move image viewer to next monitor. This only works if you have two
monitors attached to your computer.

F11

Toggle between full-screen and normal window.

Left or
Up

Scroll image if scrollbars are visible. Otherwise select previous image.

Page Down or
Spacebar or
Return

Select next image.

Page Up

Select previous image.

Right or
Down

Scroll image if scrollbars are visible. Otherwise select next image.

Ctrl + Left or
Ctrl + Up or
Ctrl + Right or
Ctrl + Down

Scroll fast if scrollbars are visible.

Shift + Left or
Shift + Up or
Shift + Right or
Shift + Down

Scroll 1 pixel at a time if scrollbars are visible.

Ctrl + I

Show/Hide image information panel.

Ctrl + L or
[

Rotate image 90° left.

Ctrl + M

Mark image checkbox.

Ctrl + N

Unmark image checkbox.

Ctrl + R or
]

Rotate image 90° right.

Alt + Left or
Alt + Down or
Alt + PageDown

Select previous image. This shortcut is especially handy in the title
areas where the arrow keys don't work.

Alt + Right or
Alt + Up or
Alt + PageUp

Select next image.
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Alt + Home

Select first image. Works also when editing titles.

Alt + End

Select last image. Works also when editing titles.
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Mouse shortcuts
Shortcut

Action

Left click

Zoom on area (when clicking the selection area).

Left click and drag

Move image (when scrollbars are visible).
Create selection area (when scrollbars are not visible).

Shift + Left click and drag

Create selection area.

Ctrl + Left click

Zoom in. The cursor is used as zoom center.

Alt + Right click

Zoom out. The cursor is used as zoom center.

Left double click

Toggle between full screen window and normal window.

Middle click

Toggle between "100% zoom" and "Zoom to fit". The cursor is used as
zoom center.

Mouse wheel

Zoom image. The cursor is used as zoom center.

Shift + Mouse wheel

Select next/previous image.

4.17.3 IPTC Window
The following shortcuts can be used in the IPTC window
Shortcut

Action

Alt + Left or
Alt + Down or
Alt + PageDown

Select previous image.

Alt + Right or
Alt + Up or
Alt + PageUp

Select next image.

10

.

4.17.4 Jpeg Comment Window
The following shortcuts can be used in the Jpeg Comment window

5

Shortcut

Action

Alt + Left or
Alt + Down or
Alt + PageDown

Select previous image.

Alt + Right or
Alt + Up or
Alt + PageUp

Select next image.

12

.

Arles Image Web Page Creator
Select the Arles Image Web Page Creator to create online web galleries. To open the Web Page
Creator click the Arles Image Web Page Creator icon in Windows. If you started with the Arles Image
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Explorer
window.

2

, click the Web Pages button on the toolbar to open the Arles Image Web Page Creator

Getting started 1
Getting started tutorial on how to create an image webpage gallery.
Files Tab 26
Setting file name and folder options.
Thumbnails Tab 31
Setting thumbnail options.
Images Tab 33
Setting image options.
Index Page Tab 35
Setting thumbnail index page options.
Image Pages Tab 46
Setting image pages options.
Titles Tab 50
Setting thumbnail, image and page title options.
Publish Files 54
Publish the generated image galleries.
HTML Templates 63
Using Arles HTML templates.

5.1

Files Tab
Quick start...

1

File locations
Source folder
Location of the original image files.
Target folder
The target folder is where all files generated by Arles will be saved. The contents of this folder is what
needs to be published to your server 54 .
Arles never overwrites original image files, which is why you cannot modify images if the source folder
is the same as the target folder. The following Target folder types are available:
Subfolder

All generated files will be put in a subfolder of the source folder. For
example, if you specified "arles_gallery" as subfolder and your images
are in "C:\Images", the generated files will be saved in "
C:\Images\arles_gallery\".

Same as source folder Arles will save all generated files in the same folder as the original images.
With this setting your original images will get mixed with files generated by
Arles. This often makes things more difficult to organize, which is why we
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don't recommend this setting.
All gallery files will be put in the defined target folder.

Other

Overwrite thumbnails and images
You can select to recreate all thumbnails and images or to only create them for new and modified
images.
Ask me

A dialog asking for overwrite confirmation will be shown every time
thumbnails are created or images are modified.

Overwrite all

Recreates all thumbnails and generated images. You have to use
Overwrite all if you changed any thumbnail or image option, like thumbnail
width or the image border style.

New and modified
only

Creates thumbnails and images for new or modified images only. Use this
option if you did not change any settings for your gallery, but just want to
add new images.
This option is faster than Overwrite all, but keep in mind that you have to
use Overwrite all if you changed any thumbnail or image options. If you
don't do so you won't see the changes.

Add subcategories
Select to create a subcategories section at the top of your index page which will link to subfolders
containing images. Subcategories are only created if you use the multi-folder processing tool 79 .

Advanced options
Click the Advanced

5.1.1

27

button to set advanced file location options.

Advanced Files Options
In the Advanced Files Options window you can specify how the files generated by Arles will be
named and in which folder they should be stored. You can also tell Arles about other user files that you
want to be included in the gallery.
File Names tab
Folders tab

28

User Files tab
5.1.1.1

27

30

File Names
The File Names tab in the Advanced Files Options window
generated by Arles should be stored.

27

allows you to specify where the files

Thumbnails
The generated thumbnails files have a different name than the original images to prevent overwriting.
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A Prefix and a Suffix can be added to the thumbnail file name. The thumbnail file name is constructed
as follows:
<Prefix>Thumbnail_FileName<Suffix>.Extension

Images
By default images have the same name as the original images. You can select to add a prefix or
suffix.

Index pages
The HTML index file name is composed of the file name (without extension) and the file extension.
Selecting index for the file name and html for the extension results in index.html for the first index file
name. The second index page will be name index2.html, index3.html, etc.. The file extension can be
either selected from the drop down list or typed directly in the edit box.

Image pages
Select Image file name if you want to name the image webpages after the original images. If the
original is called spain.jpg the page will be called spain.html.
Select User defined if you want to provide all images with a similar name. The HTML image file
names are composed of the File name (without extension) and the File extension. Selecting
imagepage for the file name (without extension) and html for the file extension, results in
imagepage.html for the first image file name. The file extension can be either selected from the drop
down list or typed directly in the edit box.
Tip: You can select a default HTML file extension for new galleries in the Web Page Creator Options
window 70 .
5.1.1.2

Folder
The Folders options tab in the Advanced Files Options window
generated by Arles should be stored.

27

allows you to specify where the files

Folder names
Thumbnails folder
Folder containing thumbnails images generated by Arles.
Image pages folder
Folder containing HTML image pages generated by Arles.
Images folder
Folder containing images copied or modified by Arles.
Original images folder
Folder containing copied original images. This folder is only created if you link the thumbnails or
images to the original images.
Navigation and background images folder
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Folder containing navigation and background images, which are used on the HTML pages.
Stylesheets folder
Location of stylesheet files (*.css).

Options
Target folder
Places the image files in the target folder

26

.

Subfolder
Places the image files in a subfolder of the target folder. Specify the subfolder name in the edit field.
You can specify multi-level subfolders by using slashes (e.g. "imagepages/images"). Relative paths
(e.g. "../../arlesimages") are also allowed. Relative paths are always in reference to the source folder. If
you want a fixed path use the User Defined option.
For the navigation images the subfolder is always with reference to the index pages. For image pages
the path is automatically corrected, to make sure there are no duplicate folders.
User defined
For experienced users only!
The user defined option allows you to specify what you want to be placed in front of each file name. It
is mostly used to specify a custom path.
You can use User Defined location if you have several image galleries on your web server and want
them to share the same navigation images to avoid duplicate images. You can do this by setting the
Navigation and background images to User Defined. Next set the User defined path to:
http://www.yourdomain.com/navigation_images/

Don't forget the trailing slash or the path will be broken. Arles will now create galleries with navigation
images like this:
<img src="http://www.yourdomain.com/navigation_images/first.png">

You will have to place the correct images in the navigation_images folder yourself.
Arles will not create files if you set the location type to User Defined. Therefore, depending on what
locations you set to User Defined, some parts of the generated gallery will be broken when you click
the Show Results button. You have to make sure that you place required files in the right location on
the web server to make things work.
When using User Defined for the images, you can also not use title tags 51 that contain information
about created images. For example, you can not use file size title tag. As Arles does not create the
images, it also does not know the size of the created images.

Folder tags
Two folder tags can be used in subfolder or user-defined folders. Both are for advanced users only
and are used in combination with the multi-folder processing 79 feature.
<FolderName>
This tag will be replaced with the source folder name. If the processed folder is
"c:\images\holidays\2005\greece", it will replace the <FolderName> tag with "greece".
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<PathFromRootFolder>
This tag only works when multi-folder processing and inserts path from the root folder to the source
folder.
If your root folder is "c:\images" and you are processing "c:\images\holidays\2005\greece", it will
replace the <PathFromRootFolder> tag with "/holidays/2005/greece". This feature is especially helpful
if your images are hosted in another location than your galleries.

Stylesheet options
Embedded
Style information is embedded in the index and image webpages. Select this option if you don't want
separate stylesheet files.
HTML folders
The style sheet files will be placed in the same folder as the index page or image pages.
User defined
For experienced users only! Several Arles layout settings may not work as expected with this option.
A user defined path is helpful if you create your own stylesheets manually and want to link to them
directly. Arles will not create stylesheets with this option selected. By default Arles appends the
template name to the path you specify. For example, if you set the user defined path to:
http://www.yourdomain.com/stylesheets/

Arles will attach the stylesheet filename and add the following link to the <head> section of the
generated index pages:
<link rel="stylesheet" TYPE="text/css"
HREF="http://www.yourdomain.com/stylesheets/index.css">

If your path ends with ".css" then Arles assumes that the path already includes a stylesheet filename.
In this case Arles will not append the default stylesheet filename. For example, if your user defined
path is set to:
http://www.yourdomain.com/stylesheets/yourstylesheet.css

Arles will add the following line to the generated HTML pages:
<link rel="stylesheet" TYPE="text/css"
HREF="http://www.yourdomain.com/stylesheets/yourstylesheet.css">

None
For experienced users only! Several Arles layout settings may not work as expected with this option.
No stylesheets and links to stylesheets will be created. The class names will still be available, which
allows you to create own stylesheets. You can link your own stylesheets by using Custom HTML 40
section or by using the Arles HTML Templates 63 feature.
5.1.1.3

User Files
The User Files tab in the Advanced Files Options window 27 allows you to select the files you want
Arles to automatically copy to the index page or image pages folder. User files are also automatically
published 54 to your webserver.
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What are user files?
You don't need the user files feature when using standard Arles layout features like navigation
banners 40 .

37

of

However, if you customize the gallery by using the HTML Templates 63 feature you may want to copy
files to the index page or image pages folder. This situation can happen if you want to add another
stylesheets. Or when you created a design with your own background images.
In all these cases you probably want to select these files as user files. Arles will then automatically
copy the files to the index page and image pages folder when generating the gallery. It will also upload
any user files to your webserver when you use the Publish Files tool 54 .

Index pages
Click the Add button in the Index pages area to select files for the index page folder. You can select
multiple files in the Open file dialog by holding the Ctrl or Shift button.

Image pages
Click the Add button in the Index pages area to select files for the image pages folder. You can select
multiple files in the Open file dialog by holding the Ctrl or Shift button.

5.2

Thumbnails Tab
Size
Use the Height and Width boxes to set the height and width of the thumbnails.
Lock aspect ratio
The aspect ratio is the relation between the image width and height. Unselect this option if you want
the thumbnail to exactly fit the height and width. However, it will make the thumbnails look distorted
depending on how much the aspect ratio of the original differ from the thumbnail aspect ratio. If you all
thumbnails to have the same size it is generally better to select the Crop to fit option.
Crop to fit
Selecting the Crop to fit 33 option if you want the generated thumbnails to fit exactly the specified size.
Any borders that do not fit will be cut off. Select the Crop Options 33 button to set the crop position.

Image Effects
Use image effects to add text labels, logos, borders, dropshadows or other effects to your your
thumbnails. Click the Options button to open the Image Effects window 57 .

Advanced options
Click the Advanced
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button to set advanced images properties.
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Advanced Thumbnail Options
To open the Advanced Thumbnail Options window in the Web Page Creator window
Thumbnails tab 31 and click the Advanced button.

25

select the

Image processing tab
Resize method
Select the resize method 75 . Lanczos 3 or Mitchell generally provide the highest quality results. Select
Only reduce thumbnails to leave images, which are smaller than the specified thumbnail width and
height unmodified.
Sharpen
Applying a sharpen effect after resizing thumbnails leads to the highest quality results. Select Apply to
resized thumbnails only if you want to apply the sharpen effect only if a thumbnail has been resized.
Filter
Select the image filter

75

to be applied to thumbnails.

Save tab
File save format
Select the default format that Arles uses to save thumbnails.
JPEG or PNG? ...

74

JPEG image quality
Use the slider to select the image quality of generated JPEG images. Better quality also means larger
file size. Generally, values between 70 and 90 are a good trade off between high quality thumbnails
and reasonable file sizes. Select 70 if you want the smallest file size with acceptable image quality.
Select 90 for good quality images with acceptable file sizes.
If you are working on a CRT monitor, keep in mind that LCD monitors show image artifacts of low
quality JPEG images sooner than CRT monitors. One other thing to keep in mind is that due to the
nature of JPEG compression, blurry images compress better than sharp ones. If small file sizes are
critical, turn off the sharpen filter or select Mitchell resize method instead of Lanczos 3 75 .

Transparency
Save transparency (requires PNG & Internet Explorer 7)
Arles can process and save PNG images with transparency information. Note, that galleries with
transparent PNG images require Microsoft Internet Explorer 7 or better. Internet Explorer 6 and older
versions contain a bug prevent transparent PNG images from showing up properly. The transparent
parts of the image will show up in a strange color on older IE versions. The Opera and Firefox web
browsers handle transparent PNG images just fine.
Use webpage background color for transparent areas
Select if you want Arles to use the webpage background color as background color for transparent
areas in the images.
Background color
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Color to be used for transparent areas, like dropshadows, in images.

Subcategories tab
Set options for subcategory
Locations 26 tab.

79

thumbnails. You can switch on subcategory generation on the File

Thumbnail size
Sets the subcategory thumbnail size. Select "Same size as other thumbnails" if you want any
subcategory thumbnails to be the same size as the standard thumbnails.
Image effects
Select image effects for subcategory thumbnails. Select "Same effects as other thumbnails" if you do
not want to specify a custom effect.

Movies tab
Set options for movie thumbnails. It is generally a good idea to indicate to the visitors of your website
that a thumbnail links to a movie instead of a normal image file. Adding a "Movie" text image effect on
the thumbnail is one way to do this.

5.2.2

Crop to fit
To open the Crop to Fit Options window, in the Web Page Creator window
tab 31 and click the Crop Options button.

25

select the Thumbnails

What is crop to fit?
The Crop to fit option will make the generated thumbnails fit exactly the specified height and width. Any
borders that do not fit will be cut off.

Crop position
The crop position specifies the focus area of the crop. Set the both horizontal and vertical positions to
50% if you want the center of the image to remain. If the important areas of your images are located at
the top, set the vertical position to 0%.

5.3

Images Tab
Resize
Your original images can be resized using the same resampling technique 75 as for creating the
thumbnails. Download times are reduced when smaller images are made available. Also, resizing an
image collection of different sizes to one standard size creates a more balanced and professional
looking site.
The aspect ratio will automatically be maintained. The height and width values are therefore maximum
values. To prevent overwriting of original images, resizing will not work when the source and target
folders 26 are identical.
As an alternative for the image resize option, size information can be added to the HTML text in the
advanced image page window 47 .
To prevent overwriting of original images, the Resize option will not work when the source and target
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folders

26

are identical.

Image Effects
Use image effects to add text labels, logos, borders, dropshadows or other effects to your your
thumbnails. Click the Options button to open the Image Effects window 57 .

Location
The destination images location can be set on the Advanced File Locations Page

5.3.1

27

.

Advanced Image Options
To open the Advanced Image Options window in the Web Page Creator window
tab 33 and click the Advanced button.

25

select the Images

Image processing
Resize method
Select the resize method 75 . Lanczos or Mitchell generally give the best results. Select "Only reduce
images" to leave images smaller than the specified width and height unmodified.
Sharpen
Applying a sharpen effect after resizing images leads to the highest quality results. Select Apply to
resized thumbnails only if you want to apply the sharpen effect only if a image has been resized.
Filter
Select the image filter

75

to be applied to images.

File save format
File save format
Select the default format that Arles uses to save images.
JPEG or PNG? ...

74

To prevent quality loss, GIF and JPEG images will only be copied and not converted if they are not
modified. You can override this behavior by selecting the Always save images option (see below).
Always save images
Select to force Arles to always save images, even when no image processing like resize is specified.
Use this if you want to save JPEG images with a new quality level without doing any other image
processing. It also comes handy if you want to save your JPEGs as PNG images or PNGs as JPEGs.
Maintain JPEG EXIF, IPTC and comment information
JPEG images can contain EXIF 10 , IPTC 10 and comment 12 information inside the image file.
Select this option if you want this information to be copied to the modified images.

JPEG quality
Use the slider to select the image quality of generated JPEG images. Better quality also means larger
file size.
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Generally, values between 70 and 90 are a good trade off between high quality images and reasonable
file sizes. Select 70 if you want the smallest file size with acceptable image quality. Select 90 for good
quality images with acceptable file sizes.
If you are working on a CRT monitor, keep in mind that LCD monitors show image artifacts of low
quality JPEG images sooner than CRT monitors. One other thing to keep in mind is that due to the
nature of JPEG compression, blurry images compress better than sharp ones. If small file sizes are
critical, turn off the sharpen filter or select Mitchell resize method instead of Lanczos 3 75 .
Tip
For top quality lossless images, select PNG images as default output graphic format.

Transparency
Save transparency (requires PNG & Internet Explorer 7)
Arles can process and save PNG images with transparency information. Note, that galleries with
transparent PNG images require Microsoft Internet Explorer 7 or better. Internet Explorer 6 and older
versions contain a bug prevent transparent PNG images from showing up properly. The transparent
parts of the image will show up in a strange color on older IE versions. The Opera and Firefox web
browsers handle transparent PNG images just fine.
Use webpage background color for transparent areas
Select if you want Arles to use the webpage background color as background color for transparent
areas in the images.
Background color
Color used for transparent areas, like dropshadows, in images.

5.4

Index Page Tab
Index table
Columns and rows
Set the columns and rows to define the thumbnail table format.
Single page
Multiple index pages, including navigation links, will be created if there are more images in the source
folder than would fit on one page. For example, if you specify 2 rows and 2 columns, multiple index
pages will be generated if there are 5 or more images in the source folder. You can force all images on
one single index page by selecting the Single page option. This will override the rows option.
Cell pad
Cell padding is the space inside each table cell.
Border
Click the Border button to edit the table and cell borders.

Gallery style
Select the style from the pull down box to set the gallery style.
Standard
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The thumbnail index page will link to separate image pages.
Index frame left
Thumbnails will be shown on the left of the images.
Index frame right
Thumbnails will be shown on the right of the images.
Index frame top
Thumbnails will be shown above the images.
Index frame bottom
Thumbnails will be shown below the images.
Click the Options button to set gallery style options

36

.

Navigation links
The navigation links are only used when multiple index pages are created.
Click the Top and/or Bottom option to select the position of the navigation links. Click the Options...
button to modify the navigation links 37 .

HTML Design
Click the HTML Design button to set the HTML page properties

40

like colors, background image, etc.

Advanced options
Click the Advanced

5.4.1

40

button to set the advanced index page properties.

Gallery Style Options
Use this window to set options for gallery styles using frames.
Index frame file name
The index frame file name is composed of a file name prefix and an extension. Selecting "myfilename"
for the file name prefix and "htm" for the default extension results in "myfilename.htm" for the index
frame file name. You can also set filenames for the main index file and the image files. The default
HTML file extension can be set in the Environment Options 70 . The main page name can be set in
the Advanced Index page options window 40 .
Frame margins
The margin width and margin height are the space inside each frame. Use this option to prevent the
contents of the HTML page to be place directly against the side of the Browser window.
Border
Set the frame border (between the index and image pages) by selecting the type from the pull down
list box.
Auto synchronize thumbnails with images
Select this option to automatically scroll the related thumbnail in view when a new image page is
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loaded.
Index frame sizes
The size of left, right, top and bottom thumbnail index frames can be automatically calculated by Arles
Image Web Page Creator. Unselect Auto to set the index frame height and width yourself.
Index frame scrolling
With auto scroll selected the thumbnail row will automatically scroll through all thumbnails. You can set
the scrolling speed and decide if you want to stop the scroll effect when hovering with the cursor above
the index frame.

5.4.2

Navigation Options
In the navigation options window you customize the looks of the navigation links on the generated
gallery pages.

Presets
Select a preset to use any of the predefined navigation styles from the drop-down list. You can save
your own navigation settings as a preset by clicking the Save as button. Click Delete to remove a
preset.
Tip
Hold the Ctrl button when clicking the Save button to save the current preset with the same name.

General
Text label
Specifies the text label of navigation item. If a button image is selected for the navigation item, the text
label will be used as alternate text (alt) for the image.
Button image
Set this field to use a button image instead of text for the navigation link. Arles Image Web Page
Creator contains many ready to use images in the buttons folder 71 . Click the browse button to select
a navigation image.
Link
The link field is only used for the Home navigation item. Use this item to include a link to your home
page (e.g. http://www.digitaldutch.com/arles).
Target
Set target to _top if you want to break out of any frames when clicking the Home navigation button or
link. Select _blank if you want to open your home page in a new window.
When generating HTML the navigation image will be copied to a sub-folder of the target folder. You
can set the sub-folder name in the Advanced File Locations window 27 .
Note, that Arles removes any unnecessary links. For example, the first index page will not contain the
First navigation link.

Index page tab
Select the checkboxes of each navigation item you want to include in your galleries.
Digital Dutch

38

Arles Image Web Page Creator Help

Navigation bar
Creates a navigation bar for multi-level galleries. This option is mostly used in combination with the
multi-folder processing tool 79 . The multi-folder root folder is also the top level for the navigation
bar.
Home
Link to your home page. Use the link field to specify the location.
Up
Go one level up. This option is mostly used in combination with the multi-folder processing tool 79 .
The Up item is not shown on the top level, which is the root folder as specified in the multi-folder
processing window.
First
Link to the first index page.
Previous
Link to previous index page.
Next
Link to next index page.
Last
Link to last index page.
Quick list
Drop down box containing quick links to all other index pages.
Index
Current index page number text (e.g. "Index 3").
Of
'Total number of index pages available (e.g. "of 10").

Image pages tab
Select the checkboxes of each navigation item you want to include in your galleries.
Navigation bar
Creates a navigation bar for multi-level galleries. This option is mostly used in combination with the
multi-folder processing tool 79 . The multi-folder root folder is also the top level for the navigation bar.
Slideshow Start/Stop
Adds a slideshow start/stop button. You must also enable the slideshow on the Image Pages tab
for the button to show up.

46

Home
Link to your home page. Use the link field to specify the location.
Index
Link to index page.
First
Link to first image.
Previous
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Link to previous image.
Next
Link to next image.
Last
Link to last image.
Quick list
Drop down box containing quick links to all other images in the gallery.
Image
Current image number text (e.g. "Image 3").
Of
Total number of images available (e.g. "of 10").

Accessibility
Select Enable shortcut keys to enable navigating generated galleries with keyboard shortcuts.
Shortcuts have a few disadvantages though, especially in the Internet Explorer.
Firefox browser
In the Mozilla Firefox web browser shortcuts work as expected. Selecting a shortcut will directly
perform the required action. For example, clicking Alt+N will load the next image page in the browser.
Internet Explorer
In Microsoft Internet Explorer shortcuts only select the navigation item in question. You always have to
click the Return key to perform the action. For example, clicking Alt+N will select the Next link. You
must click the Return key to actually load the next image page. Similarly to go to the previous page,
click Alt+P and then Return.
Note
Gallery shortcut keys will override browser shortcut keys. For example, in the English version of
Internet Explorer the Alt+F key combination normally opens the File menu . If you decide to use the
Alt+F shortcut in your gallery then the original Internet Explorer File menu shortcut will no longer work.
Therefore be careful which keys you specify, as some visitors of your pages may not like this behavior.

Options
Disabled buttons
Arles disables navigation buttons when they have no function. For example, the First button is disabled
on the first image page.
Select Hide if you want hide buttons which are disabled. Select Replace with spacer to replace
disabled buttons with a similar sized space. This will lock the button better in its place on the web page
and prevent "jumping" buttons which some users find awkward.
Navigation layout
Select Use table to add a HTML table structure around the navigation links. The table structure is
required to set the spacing between the navigation items. Uncheck the Use table option to enable
wrapping of the navigation links in smaller browser windows.
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HTML Design Options
The HTML Design window allows you to set the design of the generated index and image pages.
To open the HTML Design window:
· In the Arles Image Web Page Creator
· Click the HTML Design button.

25

window select the Index Page tab or Image Pages tab.

Layout
On the layout tab you can set the default colors and background image for the generated webpages.
Title fonts can be set in the Font and Style Options 52 window.

Banners
To add a banner:
· Select the Top or Bottom checkboxes to add a banner to the generated webpages.
· Select the image you want to use for your banner in the Image box.
· Set the link of your banner to a fully valid website link like http://www.digitaldutch.com. Make sure
you add the "http://" part if you want the banner to work on any webserver.
· The Alt text is the text that appears when the banner is not yet fully loaded. It is also used as a
tooltip.

Custom HTML
Custom HTML allows you to add your own HTML code to the generated webpages. The custom
HTML at the top of the page will be located directly below the top banner. The custom HTML at the
bottom of the page will be located directly above the bottom banner.
Use HTML added to page <head> section to insert all code you want to include into the page head
section. This option comes in handy for advanced users who want to add their own Javascripts or
META tags.

Image pages
By default the image pages have same design as index page(s). Uncheck Image pages have same
design as index page(s) to specify a different design for the image pages.
For Image Pages you can use title tags 51 in the Custom HTML code to add specific image
information like . Right click the Image Pages Custom HTML memo fields to insert title tags.
Tip
Use templates

5.4.4

63

for maximum control over the HTML page design.

Advanced Index Page Options

To open the Advanced Index Page Options window, in the Arles Image Web Page Creator select the
Index Page tab and click the Advanced button.
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Advanced Index Page Options
General 41
General index page options.
Table 42
Thumbnail table options.
Border 42
Table and cell border options
Thumbnail 43
Thumbnail layout options.
Thumbnail Links 44
Thumbnail links options.
Popups 45
Popup options.
Options 46
Label and print service options.
5.4.4.1

General
The following options are available on the Advanced Index Page Options

40

window General tab.

Page layout
Page alignment
Sets the horizontal alignment of the index page.

Security
Disable right clicking
Select if you want a warning to pop-up whenever a visitor right-clicks a thumbnail. This feature can be
used to protect your images from being easily saved. Click the Options button to change the message
that will be shown.
This protection is quite weak and can be easily worked around by disabling JavaScript in the browser
or by taking a screenshot. We recommend to add some text 59 or logo 60 on the images themselves
instead. You may also want to consider that many visitors use their right-click menu for other purposes
and may be annoyed when they find out it does not work on your webpages.
You can disable right-clicking images in the Advanced Image Pages Options window

48

.

Options
Add link to Arles Web Site
Uncheck "Add link to Arles Web Site" to remove the Arles Web Site link from your index page(s). This
option can only be disabled in the registered Arles version 2 . You can disable the Arles links for all
galleries in the environment options 70 .
Automatically launch from CD (CD Autorun)
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Select if you want to create an image gallery that is automatically launched from a CD. Arles will add
two files (autorun.inf and arlesrun.exe) to the gallery target folder to enable this windows feature.
Text-only gallery (Thumbnails will not be visible)
Select if you want to create a gallery with text links only. The thumbnails will not be shown on the index
pages.
Text-only subcategories (Subcategory thumbnails will not be visible)
Select if you want to create a gallery with text-only links to subcategories 79 . The subcategory
thumbnails will not be shown on the index pages.
5.4.4.2

Table
The following options are available on the Advanced Index Page Options

40

window Table tab.

Table options
Table width
Specify a fixed (e.g. 600 pixels) or relative (e.g. 90%) width for the thumbnail table.

Table design
Color pattern
The following table color patterns are available:
Color pattern

Description

[None]

No table color applied.

Single Color

The complete table has a single background color.

Single Color (Cells only)

All table cells have the same background color. The spacing between the
cells shows the page background color.

Horizontal stripes

Table rows have alternating colors.

Vertical stripes

The vertical table columns have alternating colors.

Checked

Table cells are colored in a checkerboard pattern.

Background image
Thumbnail table background image.
5.4.4.3

Borders
The following options are available on the Advanced Index Page Options

40

window Borders tab.

Table border options
Width
Width of table border. Set the border width to zero to remove table borders.
Border style
The following border styles are available:
Style

Description
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All

All borders are shown

Around cells

Borders are drawn around each table cell. The Cell spacing has to be 1 or
larger for this option to work.

Around cells & table

Borders are drawn around each table cell and around the full table. The
Cell spacing has to be 1 or larger for this option to work.

Below

Horizontal borders are drawn below each table row.

Inside

Only borders inside the table are shown.

Inside horizontal

Only horizontal borders inside the table are shown

Cell spacing
The cell spacing is the space between table cells. It is only enabled for some border styles like Around
cells.
Line style
Select the border line style. Some styles, like double or groove, need the border width to be 2 pixels
or larger.
Color
Color of border.

Thumbnail border options
Set the Thumbnail HTML Border to specify a HTML border width for the thumbnails. It is
recommended to use Image Borders instead. Image Borders create borders directly in the images and
allow special effects like 3D and button style borders. You can specify Image and Thumbnail Borders
in the Image Effects Window 57 .
Due to HTML limitations the color of the HTML border will be same as the selected HTML Text Color.
The Text Color can be set in the HTML Design Options Window 40 .
5.4.4.4

Thumbnail
The following options are available on the Advanced Index Page Options

Thumbnail / title layout
Title location
Location of title relative to thumbnail.
Title/thumbnail margin
Margin between title and thumbnail image.
Thumbnail alignment
Thumbnail table cell alignment
Title text alignment
Horizontal alignment of title text.
Cell vertical alignment
Vertical alignment of thumbnail table cell

Cell size
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All cells have same width
Select if you want all cells in the thumbnail table to have same width. Arles will automatically calculate
and set the width for all columns.
Width
Thumbnail table cell width.
Height
Thumbnail table cell height.

5.4.4.5

Thumbnail Links
The following options are available on the Advanced Index Page Options
tab.

40

window Thumbnail Links

Links
Link what?
Select which part of the thumbnail should be linked.
Link to
Specifies where the thumbnails are linked to.
[None]

No thumbnail links will be created. Select this option if you don't need
Image Pages and only want to create Index Pages.

Image pages

Default option. A Image Page is created for each image. This page can
contain navigation items or any other options you specify on the Image
Pages Tab 46 .

Image pages (popup)

The image pages are shown as popup windows. When selected a Popup
tab 45 will appear that allows you to set all popup options.

Image pages (with
original images)

Arles will create image pages with original images. Use this option if you
only want to create webpages without changing the images.

Images

Links directly to the modified images. No Image Pages are created.

Images (popup)

The images are shown in a popup window. No Image Pages are created.
When selected a Popup tab 45 will appear that allows you to set all
popup options.

Original images

Images will only be copied, not modified. The thumbnails will link directly
to these original images. For example, for a TIFF image the link will be
directly to this TIFF image.

Custom link

Links to the URL specified in the custom link field. You can insert image
links and titles in this field by using <FileLink>, <FileTitle1>, <FileTitle2>,
<FileName> or any other title tags 51 . Click the drop down button to
select tags. Image links and titles can be set in the Arles Image Explorer
2 .

Link Target
Select a Thumbnail Link Target if you want to add a HTML target attribute to the thumbnail link tag.
Link non-images, like movies, always to the original files
Select if you want the thumbnails of non-images to be linked directly to the original files. For example,
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a thumbnail for a movie will be linked to the movie file and a thumbnail for a URL file will be directly
open the Internet Page defined in the URL.
See also:
· How to create a gallery from movies? 81
· How to create galleries of web pages? 80
5.4.4.6

Popups
The image pages or images can be shown in a popup window if you set the link thumbnails to 44 to
Image pages (popup) or Images (popup). The Popups tab will only be visible if you select one of
these two options.
The following options are available on the Advanced Index Page Options

40

window Popup tab.

Size
Auto
Arles will estimate the optimal size for the popup window. This will work fine generally, but sometimes
you will have to set the width and height manually.
Fixed
Select if you want to set the popup window width and height manually.
Full screen
Arles will show the popup window in full screen view. Note that some visitors may not allow your
website to resize the browser to full screen. In addition, this options can only be selected with the
Image pages (popup) link type.

Close
Add close link
Select if you want Arles to add a close link to the popup window. Visitors can click this link to close the
popup window.
Clicking the image closes the popup window
When selected, the visitor can click the image to close the popup window.
Close text
Text that will appear for the close link.
Close button image
Select a button image in this field if you prefer a close button instead of a close text. The Close text
will be used as button tooltip.

Options
The following options can be set for popup windows:
Resizeable window
Makes the popup window resizeable.
Show statusbar
Adds the statusbar to the popup window.
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Open each image in same window
Select if you want the same popup window to be used for each image. Unselect, if you want multiple
popup windows to appear.
Show scrollbars
Adds scrollbars to the popup window if the popup contents does not fit completely in the popup
window.
Show toolbar
Adds the toolbar to the popup window.
5.4.4.7

Other
The following options are available on the Advanced Index Page Options

40

window Other tab.

Online Print Service
Arles can automatically add links to online print services like Shutterfly.com (United States) and
Photocolor.ch (Germany and Switzerland). Click the Options button to set online print service options.
Note, that this feature is still experimental, so we cannot warrant that this function is error free or
meets your requirements.

Labels
No images text
This text will be shown when a gallery has no images. It is mostly used in the multi-processing mode
79 .

5.5

Image Pages Tab
HTML design
Select the custom option and click Edit... to set the HTML page properties
image) for the image pages manually.

40

(e.g. colors, background

Select the Template option to obtain full control over the web page HTML design. Click the Browse
button to open the template window 63 .
Navigation links
Check the Top and/or Bottom options to add navigation links to the image pages. Click the Options...
button to modify the navigation links 37 .
Slideshow
Select Add slideshow to automatically browse through your image pages. Click Options to open the
Slideshow Options window 46 .
Advanced options
Click the Advanced

5.5.1
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button to set the advanced image pages properties.

Slideshow Options
This window allows you to set all slideshow options. A slideshow allows you to automatically load the
next image after a predefined delay time.
Delay
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The delay specifies after how many seconds the next page will automatically load.
At end
Select the At end action to specify what happens after the last image has been loaded.
Go to index page
The index page will be loaded after the last image.
Restart
The first image will be loaded after the last image.
Stop
The slideshow will stop at the last image.

Add Start/Stop button
To allow users of your slideshow to temporary stop and restart an image gallery, add a Start/Stop
button. You can specify button properties in the Navigation Options window 37 .

Status bar messages
The time remaining until the next image is loaded can be shown in the status bar of the Browser
window. The text fields allow you to modify all parts of the slideshow status bar messages.

Technical information
For several advanced slideshow features like the Start/Stop button and status bar messages
JavaScript will be added to the generated HTML pages. Simple galleries will be created by adding a
META refresh tag to the HTML page headers.
Tip
To automatically start the slideshow on your web site, link directly to the first image page instead of the
index page.

5.5.2

Advanced Image Pages Options
To open the Advanced Image Pages Options window, in the Arles Image Web Page Creator select
the Image Pages tab and click the Advanced button.

Advanced Image Pages Options
General tab 48
Set general options.
Image Links tab 49
Set image link options.
Movies tab 49
Set movie options.
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Effects tab 50
Set page transition effects.
Other tab 50
Set Online Print Service options.
5.5.2.1

General Tab

Page layout
Page alignment
Sets the horizontal alignment of the image pages.
Image HTML border
Set the Image HTML Border to specify a HTML border width for the images. It is recommended to use
Image Borders instead. Image Borders create borders directly in the images and allow special effects
like 3D and button style borders. You can specify Image Borders in the Image Effects Window 57 .
Due to HTML limitations the color of the HTML border will be same as the selected HTML Text Color.
The Text Color can be set in the HTML Design Options Window 40 .

Security
Disable right clicking
Select if you want a warning to pop-up whenever a visitor right-clicks an image in your gallery. This
feature can be used to protect your images from being easily saved. Click the Options button to
change the message that will be shown.
This protection is quite weak and can be easily worked around by disabling JavaScript in the browser
or by taking a screenshot. We recommend to add some text 59 or logo 60 on the images themselves
instead. You may also want to consider that many visitors use their right-click menu for other purposes
and may be annoyed when they find out it does not work on your webpages.
You can disable right-clicking thumbnails in the Advanced Index Page Options window

41

.

Options
Add link to Arles Web Site
Uncheck "Add link to Arles Web Site" to remove the Arles Web Site link from your index pages. This
option can only be disabled in the registered Arles version 2 . You can disable the Arles links for all
galleries in the environment options 70 .
Preload next image
Select if you want the next image in the gallery to be loaded in the background while the visitor is
looking at a image page. With this option the next page will load much faster as the image is already
loaded. This feature is especially useful for people that visit your image gallery with a slow Internet
connection.
Disable Internet Explorer image toolbar
Microsoft's Internet Explorer automatically shows a toolbar for large image that allows visitors to easily
save or print the image. Select this option if you want to hide this toolbar.
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Image Links Tab
Specifies where the images are linked to.
Link images to
Specified what happens if you click the image.
[None]
Next image
Index page
Original image
Close window
Custom link

Default option. No image links are created.
Links the image to the next image. The last image links to the first image.
Links the image to the index page.
Links the image to the original image. Select this option if you want to show your
images and provide visitors with the option to download the originals.
Clicking the image will close the window. This is especially handy when the
image pages are popup windows.
Links to the URL specified in the custom link field. See below.

Link target
Select a Image Link Target if you want to add a target argument to the image link tag.
Custom link
The Custom link field is only visible if the Link images to field is set to Custom link. You can insert
image links and titles in this field by using <FileLink>, <FileTitle1>, <FileTitle2>, <FileName> or any
other title tags 51 . Click the drop down button to select tags. Image links and titles can be set in the
Arles Image Explorer 2 .
Link non-images, like movies, always to the original files
Select if you want the images of non-images to be linked directly to the original files. For example, a
thumbnail for a movie will be linked to the movie file and a thumbnail for a URL file will be directly open
the Internet Page defined in the URL.
This setting is ignored for movie files if you have embedded movies
See also:
How to create a gallery from movies?
5.5.2.3

49

switched on.

81

Movies Tab
Embed movies
Embeds movies in the image webpage using the Microsoft Windows Media Player control. If you do
not embed movies the poster frame 13 will be shown instead, which may be preferable if you want to
link the thumbnails or poster frame to the movie file 81 .

Embedded player options
Auto-start
When selected the movie starts playing as soon as the webpage is loaded. Without this setting the
visitor needs to click the Play button on the embedded player first.
Show controls
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shows movie controls toolbar at the bottom of the embedded movie.
Fit movie to player
When selected the movie will be scaled. If not selected the movie will be shown at 100% if it is smaller
than the embedded player.
5.5.2.4

Effects

Page transition effects
Add transition effect (Internet Explorer only)
Select if you want to have dynamic transition effects when loading an image page. The effects only
work in the Microsoft Internet Explorer webbrowser. The reason for this is that there is not standard for
page transitions. Other browsers like, Firefox or Opera, will just ignore any specified effects.
Type
Select the type of transition effect. Random will assign each image page with a random transition
effect.
Duration
Duration of transition effect. Internet Explorer does not allow durations larger than 2 seconds.
5.5.2.5

Other Tab

Online Print Service
Arles can automatically add links to online print services like Shutterfly.com (United States) and
Photocolor.ch (Germany and Switzerland). Click the Options button to set online print service options.
Note, that this feature is still experimental, so we cannot warrant that this function is error free or
meets your requirements.

Image size information
Note: We do not recommend to use this option. Your images will show up in an inferior image quality.
Use the Image Resize option on the Images Tab 33 in the Main Window instead.
Arles automatically sets the width and height tags of images to make sure the generated gallery page
loads faster. Select the Set Image Size Information checkbox to override the default image height and
width. The Browser will rescale the image to the selected size.
However, web browsers resize images in an inferior way compared to Arles. Therefore we recommend
not to use this option. This is option is available because some users find it convenient to set the width
to 50% to make sure the image always fits in the browser window, even if this reduces the image
quality. To maintain correct image proportions (aspect ratios), select either width or height, but not
both. Did we mention that we don't recommend to use this option?

5.6

Titles Tab
Index page
Gallery title
The gallery title is shown at the top of the index pages. You can use folder title tags 53 like
<FolderName> tag to insert the source folder name into the gallery title. The easiest way to insert title
tags is in the Advanced Title Options window 51 .
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Thumbnail title
To set thumbnail titles, select a title type. Click the Location button for more options

43

51

.

Image pages
Image titles
To set image titles, select a title type and location.
Navigation quicklist
The navigation quick list title is the title shown in the quick list drop down box in the navigation bar. The
quick list will only appear if it is selected in the gallery navigation window 37 .
Fonts
Click the Fonts

52

button to set title font styles.

Advanced title options
Click the Advanced button to open the Advanced Title Options Window

51

.

Tip
You can put titles directly in your images by selecting the Add text option on the Images tab

5.6.1

33

.

Advanced Title Options
To set titles, select a title type on the left and type the title text in the Type title field. You can insert title
tags by selecting them from the right side Tags area.

Index page titles
Gallery title
Title appearing on top of the index page.
Page caption
Text appearing in the caption of the Browser window when the index page is loaded.
Thumbnail table title
Title appearing above the thumbnails table.
Thumbnail title
Thumbnail titles. The position can be set with the locations listbox.
Thumbnail tooltip
The tooltip appears when you hover in your browsers over a thumbnail. Both the "alt" and "title"
attributes are set.
Subcategories title
Title appearing above the subcategory thumbnails table.
Subcategory thumbnail title
Title appearing below or above the subcategory thumbnails. The position is the same as the thumbnail
title position.
Subcategory thumbnail tooltip
The tooltip appears when you hover in your browsers over a subcategory thumbnail. Both the "alt" and
"title" attributes are set.
Digital Dutch
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Image pages titles
Page caption
Text appearing in the caption of the Browser window when an image page is loaded.
Image titles
Image titles. The position can be set with the locations listbox.
Image tooltip
Alternative text for image. This title appears when you hover with your cursor over an image in your
Browser.
Navigation quicklist
Title appearing in the quick list navigation item

37

on the index page.

Title tags
Title tags are a way to insert folder and image specific information in the titles. You can use, for
example, the <FolderName> tag to insert the source folder name into the title. Or use <FolderTitle> to
insert the folder title, which you can set in the Arles Image Explorer 6 . Or you can use the
<FileSize> in the thumbnail title to insert the file size of the generated image.
· Available Image Title Tags
· Available Folder Title Tags

53
53

.

Tips
· You can specify titles 5 for each image in the Arles Image Explorer 2 . Title tags can also be used
in the Title 1 and Title 2 areas in the Image Explorer and in the custom HTML area for the Image
Pages.
· You can use HTML in the title area, if you switch on the Allow HTML in Titles 70 option in the Web
Page Creator Options window.
· To modify date and time formats select Regional Options in the Windows Control Panel.
· Text can also be added to your thumbnails and images 59 by using the image effects window 57 .

5.6.2

Font and Style Options
Use the Font and Style Options window to set the font types and sizes for all titles. You can set the
default page font colors in the HTML Design 40 window.

Open the window
To open the Font and Style Options window:
· In the Web Page Creator 25 window select the Edit menu > Font and Style Options.
or
· In the Web Page Creator window select the Titles tab 50 .
· Click the Fonts button.

Change a title font
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To change a title font:
· Select the Title item on the left .
· Change the font style using the Font Type, size and color controls.

5.6.3

Image Title Tags
The following Arles title tags can be used in titles and other fields supporting image title tags:
Name
File date (long format)
File date (short format)
File index

Tag

File link
File name
File name without
extension
File size
File time
File title 1
File title 2
Image bit depth
Image color type

<FileLink>
<FileName>
<FileNameNoExt>

Image colors

<ImageColors>

Image EXIF information
Image EXIF summary
Image EXIF date
Image EXIF tag

<ImageExif>
<ImageExifSummary>
<ImageExifDate>
<ImageExif Tag="DateTime">
<ImageExif Tag="ExposureTime">

<FileDateLong>
<FileDateShort>
<FileIndex start=10 digits=2>

<FileSize>
<FileTime>
<FileTitle1>
<FileTitle2>
<ImageBitDepth>
<ImageColorType>

etc.
Image height
Image IPTC information
Image IPTC tag

<ImageHeight>
<ImageIPTC>
<ImageIPTC Tag="Caption">

Image JPEG comment
Image page file name
Image pixels with unit label (e.g. 1.3 megapixels)
Image width
Original file name
Original file size
Original image height
Original image pixels with unit label (e.g. 1.3 megapixels)
Original image width

<ImageJPEGComment>
<ImagePageFileName>
<ImagePixels>
<ImageWidth>
<OriginalFileName>
<OriginalFileSize>
<OriginalImageHeight>
<OriginalImagePixels>
<OriginalImageWidth>

You can also use folder title tags

5.6.4

53

in image titles.

Folder Title Tags
The following title tags can be used in titles and other fields supporting folder tags:
Name
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Arles file name
Folder image count
Folder total image
count (including
subfolders)
Folder last modified
date (long format)
Folder last modified
date (short format)
Folder name

5.7

<ArlesFileName>
<FolderImageCount>

The file name of the Arles settings file.
Number of images inside the source folder. When
used inside a subcategory thumbnail title it only
works when multi-folder processing.
<FolderImageTotalCount>Total number of images inside the source folder
including subfolders. This tags only works when
multi-folder processing.
<FolderDateLong>
Last modified date of source folder (long format)
<FolderDateShort>

Last modified date of source folder (short format)

<FolderName>

Folder name. If the source folder is
"C:\Images\Holidays\France", this tag will insert
the name of the folder "France".
Folder title as specified in the Arles Image
Explorer 2 .

Folder title

<FolderTitle>

Folder title or name

<FolderTitleOrName>

Source folder

<SourceFolder>

Target folder

<TargetFolder>

Gallery title

<GalleryTitle>

Inserts the folder title or the folder name if no title
has been specified.
Full source folder path as specified on the File
Locations tab 26 .
Full target folder path as specified on the File
Locations tab 26 .

Publish Files
For others to be able to see your gallery on the Internet, you have to upload all generated files to a web
server. To open the Publish Files window in the Arles Image Web Page Creator window 25 select
the Tools menu > Publish Files.

Publish what?
Select what you want to publish to your web server.
Created Gallery
Publish all files of the current gallery. Subfolders are not included. If you want to upload multiple
galleries use the "All Files in Folder" option.
All Files in Folder
All files in the selected local folder will be uploaded. Generally you want to set this to the Target folder
as specified in the main window. Select Include subfolders if you also want to publish the files located
in subfolders.
The All Files in Folder upload option is not limited to gallery files created by Arles. If you want you can
upload your complete website with this option.

Publish where?
Select where you want to publish your gallery. Click the Edit button to set the publish location

56

.

Actions
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Publishing your files goes in three steps.
1. Find & Check
Click the "Find Check" button to find the files to be uploaded. Arles will also connect to your web
server to check which files have been modified.
At this stage you can still check or uncheck files that you want or don't want to be uploaded. By default
Arles selects only files that are modified, making the upload process much faster if only a few files
have been modified. If you want to upload all files select all files (Ctrl+A) and select the File menu >
Select Checkbox.
2. Publish
Click Publish Now to upload all selected files to the web server.
3. Show website
Click the Show Website button to view the uploaded gallery in the default Windows browser. You can
specify the URL for show in the Publish Location window 56 .
After you uploaded everything to your web server you can link from other Web pages to the generated
image gallery by creating a link to the index file. The index file is named index.html by default, but it
can be renamed in the Advanced Files Options window 27 .

View
All Files
Shows all files.
Modified Files Only
Shows the modified files only.
View log
Shows the publish log. This can be handy for trouble shooting if uploading does not work as expected.

Options
Publish Location
Opens the Publish Location window
Publish Options
Opens the Publish Options window

.

56

57

.

Third party FTP tools
It is recommended to use the Arles Publish function. But if you prefer to use a third party FTP tool to
upload your gallery, make sure you upload images in the binary mode. Uploading images in the ASCII
mode, will often result in corrupted images.
All generated HTML pages and images are located in the target folder as specified on the File
locations tab 26 in the main window. The generated thumbnails are, by default, located in a subfolder
named 'thumbnails'.
To publish the pages on an Internet server the complete contents of the Target folder
(including the thumbnails subfolder) must be copied to the server.
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Publish Location
Arles uses the FTP protocol to upload your gallery to your web server. Ask your Internet Service
provider or your system administrator if you don't know what to put here.

Title
This is a user friendly name for the publish location settings specified in this window.

Presets
You can save and load the options in this window by using the preset box, save and delete buttons.
This is handy if you publish multiple galleries to the same server.

FTP Server tab
FTP server
Name of the ftp server (eg ftp.yourdomain.com).
User name
The user name you use to login into the FTP server. Select Anonymous if your server does not require
a login and password.
Password
FTP password required to login into the FTP server.
Remote folder
Remote folder on your server where you want the uploaded gallery to be placed (eg
/home/yourname/www/gallery/ or gallery/). Your web host has generally provided you with a folder
where you web site files should be placed to show up on the Internet. To make sure your default web
pages are not overwritten, it is recommended to put the gallery in a subfolder or the main website
folder.
URL for show
The Publish Files window
browser. You

54

contains a Show Website button which opens the uploaded gallery in a

Use passive FTP
Some firewalls don't allow active FTP. Select this option is you are having problems connecting
through a firewall.

Proxy tab
Select this option if you connect to the Internet through a proxy server. Most people don't use this
option.

Test
Click the Test button to check if Arles can connect to your FTP server.
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Publish Options
Find & Compare Options
Mark files that should be deleted from server
By default Arles deletes old gallery files from your web server when they are no longer in use by the
gallery. Unselect this option if you don't want files marked as "Delete from server" to be selected.

Publish Options
Number of simultaneous connections
Arles can upload multiple files at the same time. This options sets the number of parallel connections.
Five (5) is generally a safe choice for maximum upload speed.
Some FTP servers do not like applications to initiate multiple connections. In your server is one of
those, set the number of connections to one (1) and switch off the Keep Alive feature which also uses
a parallel connection.
Timeout after no server response for 30 seconds
If a connection is broken Arles will keep trying to send data to the server for the time you specified
here. After this timeout period an error will be shown.
Retries if connection is broken
If an connection to your server fails or an error occurs Arles will retry the upload action for the number
of times you specified here.
Send 'keep alive' signal during transfers
Some buggy firewalls and routers kill long FTP connections, because they think it is no longer in use.
The keep alive feature is a work around for this problem. It periodically communicates with the FTP
server in an effort to convince these firewalls and routers that the connections is still alive.

Confirmations
Confirm before publishing files
Select if you want to be warned before files are published to your server.
Warn before deleting files from server
Select if you want a warning dialog to be shown before any files are deleted from your server.
Warn if remote folder does not exist
Select if you want to be warned before the remote folder is created on the server in case it did not
exist.

5.8

Image Effects
Use image effects to add text labels, logos, borders, dropshadows or other effects to your thumbnails
and images. The active effects are shown in the left-side list view. The center panel allows you to
change the settings for the focussed effect. The right panel shows a live preview of what the final
result will look like.
To open the image effects window:
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1. In the Web Page Creator window 25 select the Thumbnails or Images tab.
2. Click the Image Effects Options button.
To add a new effect:
1. Click the Add button.
2. Select an effect.
3. Recreate your gallery by clicking the All or Thumbnails button in the Web Page Creator window.
To delete an effect:
1. Select the effect you want to delete.
2. Click the Delete button.
3. Recreate your gallery by clicking the All or Thumbnails button in the Web Page Creator window.
To cancel all changes since the last gallery file save:
1. Click the Reset button.
To quickly enable or disable an effect:
1. Select or unselect the checkbox in front of the effect name.

Available image effects
Text

Add a text label on the image. The text can be customized using wide range of
text effects like the watermark effect, drop-shadow, rotation, transparency,
outline and background.

59

Logo

Add a logo on the image.

60

Solid Border
Drop Shadow
3D Bevel
Button

Adds a shadow to the image. Drop shadows do not work if background images
are specified for the page or table.

61

3D bevel type. Color can not be set for this border type.

61

Button type border.

61

Inverted button
Image overlay
Mask

Simple single color border. Set the transparency to create a simple transparent
border.

61

62

61

62

Button type border with reversed color gradient.
An image overlay file is used for the border. See below for information on how to
add your own image border files to Arles.
Uses an image mask or overlay to create special effects borders like ragged or
eroded edges. See below for information on how to add you own mask files to
Arles.

Grayscale

Converts the image to grayscale colors.

Sepia

Converts the image to sepia colors.

Rotation

Rotates the image.
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Presets
You can select any of the predefined image effects from the Presets drop down list. Click the Save as
or Delete buttons to add or delete presets.

5.8.1

Text labels
Text labels can be added to thumbnails and image in the Image Effects window

57

.

To add text labels to images or thumbnails:
1.
2.
3.
4.
5.

In the Web Page Creator window 25 select the Images or Thumbnails tab.
Select Image Effects Options button.
In the Image Effects Window click the Add button > Text.
Type the text to show on your images in the Text edit box.
Recreate your gallery by clicking the All or Images button in the Web Page Creator window.

Adding text labels and logos
website.

60

is a efficient way to discourage people from copying images from your

Text Options
Position
Select the preferred position from the Type drop down box. You can also position the text by clicking
with your mouse in the example image.
Clicking in the image will set the X and Y offset values. These values are always with reference to the
position type. For example, if you selected the right bottom position in the Type drop down box. then
right bottom position will also be the zero reference position.
Font
Set the image font type by clicking the font browse button.
Anti-aliasing smoothes the edges of the fonts to make them more readable. Anti-aliasing only works
with Windows NT/2000/XP or better.
Text background
Adding a background generally makes the image text more readable. Select Full Width if you want the
background displayed over the complete image width. Selecting Rounded will create a rounded
rectangle.
A border can be specified by setting the Border Width. Select zero if you do not want the border to
show. The Horizontal Margin is the margin inside the background box. Set the horizontal and vertical
margins to increase or decrease the background.
Transparency
Set the transparency of the text on the image. The Background only option allows setting a transparent
background in combination with opaque text.
Watermark
Select watermark to let the text appear as a 3D watermark in the images. Select Reversed to switch
the 3D effect from in to out.

Digital Dutch

60

Arles Image Web Page Creator Help

Tags
Right click the Text edit box to insert title tags. Title tags 51 allow adding image information and image
titles in the image text. While the example image will still show the tag, Arles will replace them with the
relevant information when creating the image gallery.
The file size title tag can not be used, because the image file size can not be determined while the
image is still being created.
Tip
The best watermarks are created with high contrast colors (e.g. black and white).

5.8.2

Logos
Text labels can be added to thumbnails and image in the Image Effects window

57

.

To add text labels to images or thumbnails:
1.
2.
3.
4.
5.

In the Web Page Creator window 25 select the Images or Thumbnails tab.
Select Image Effects Options button.
In the Image Effects Window click the Add button > Logo.
Select the logo filename in the Logo filename edit box.
Recreate your gallery by clicking the All or Images button in the Web Page Creator window.

Adding text label
website.

59

and logos is an efficient way to discourage people from copying images from your

Logo Options
Position
Select the preferred position from the Type drop down box. Set the X-offset and Y-offset values to
move the logo with reference to the position type..
Transparency
Set the transparency of the logo on the image.
Rotation
Changes the rotation angle of the logo.
Scale
Increases or decreases the size of the logo.
Watermark
Select Use watermark to embed your logo as a 3D watermark in the images. Select Reversed to
switch the 3D effect from inward to outward. The intensity setting increases the watermark contrast.
Tip:
Create a high contrast grayscale version of your logo for the best watermark results.
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Borders
Borders can be added to thumbnails and image in the Image Effects window

57

.

To add borders to images or thumbnails:
1.
2.
3.
4.

In the Web Page Creator window 25 select the Images or Thumbnails tab.
Select Image Effects Options button.
In the Image Effects Window click the Add button > Solid Border or 3D Bevel or Button or Drop
shadow.
Recreate your gallery by clicking the All or Images button in the Web Page Creator window.

Solid border
Single color border.
Options
Width

Width of border.

Transparency

Transparency of border. Set to zero for an opaque border. Select hundred for a
fully transparent border.

Color

Border color.

Blur Width

Controls the blur of the drop shadow edges. The shadow will soften with higher
blur values.

Symmetric border

For drop shadows only. Select to have borders on all sides of the image, not
only on the drop shadow sides. Works best in combination with a background
color.

3D bevel
3D bevel type border

Button
Button type 3D border. For options see Solid Border above.

Inverted button
Inverted Button type 3D border. For options see Solid Border above.

Drop shadow
Adds a rectangular drop shadow.
Drop shadow options
Offset to right bottom location.
Offset
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Transparency

Transparency of border. Set to zero for an opaque border. Select hundred for a
fully transparent border.

Blur Width

Controls the blur of the drop shadow edges. The shadow will soften with higher
blur values.

Color

Border color.

Symmetric border

For drop shadows only. Select to have borders on all sides of the image, not
only on the drop shadow sides. Works best in combination with a background
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color.
Note:
You can set HTML borders for the thumbnails and images on the advanced index page option window
40 and advanced image pages options window 47 .

5.8.4

Image Overlays
With image overlays an special overlay image is added to the thumbnails or images. It allows the
creation of very realistic effects like, wooden borders, a paperclip in the corner or 35mm frames.
Image overlays can be added to thumbnails and image in the Image Effects window

57

.

To add image overlays to images or thumbnails:
1.
2.
3.
4.
5.

In the Web Page Creator window 25 select the Images or Thumbnails tab.
Select Image Effects Options button.
In the Image Effects Window click the Add button > Image Overlay.
In the options panel select an image overlay type.
Recreate your gallery by clicking the All or Images button in the Web Page Creator window.

Adding your own image overlays
Arles allows you to add your own Image Overlay effects. An overlay image is a PNG file with
transparent areas. The transparent areas is where the original image or thumbnails will show up.
To add your own overlay image:
1. create an image in your favorite image editor. Make sure it contains transparent areas where the
original images should show up.
2. Save it as a PNG file with transparency.
3. Copy the file to the border images subfolder of the Arles folder, which is located at:
C:\Program Files\Digital Dutch\Arles Image Web Page Creator\border images\

4. Restart Arles to make the file show up in the Image overlay options panel.

5.8.5

Masks
Masks are used to make part of the thumbnails or images transparent. It allows you to create ragged,
wavy or rounded borders. But can also be used to apply special effects like rain, confetti or creating
images in any shapes (start, dog, fish, etc). Masks can be added to thumbnails and image in the
Image Effects window 57 .

To add masks to images or thumbnails:
1.
2.
3.
4.
5.

In the Web Page Creator window 25 select the Images or Thumbnails tab.
Select Image Effects Options button.
In the Image Effects Window click the Add button > Mask.
In the options panel select an image Mask type.
Recreate your gallery by clicking the All or Images button in the Web Page Creator window.
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Creating your own masks
Arles allows you to add your own mask effects. A mask file image is an grayscale PNG file.
To create your own masks:
1. Create a mask file using your favorite image editor. The black parts in the mask file will show the
image, the white areas are be fully transparent. Gray colors areas are semi-transparent.
2. Save the mask file it as a PNG file. (Arles only accepts PNG for mask files).
3. Copy the file to the border masks subfolder of the Arles folder, which is located at:
C:\Program Files\Digital Dutch\Arles Image Web Page Creator\Masks\

4. Restart Arles to make the mask show up in the Mask options panel.

5.9

HTML templates
Using the Arles standard interface you can customize most aspects of your image galleries. For full
control you can use HTML templates.
To open the HTML Templates window:
· In the Arles Image Web Page Creator

25

window select the Edit menu > HTML Templates.

How do HTML templates work?
Arles uses HTML templates to generate galleries. The template tell Arles where to put gallery elements
like the thumbnail index table, the navigation items, gallery title, etc. Template files are HTML files that
contain Arles template tags 64 and can be edited with your favorite HTML or text editor.
Two words of caution. Templates require some HTML knowledge and changing templates might
disable some of the Arles features. For example, if you remove the Title section from the template, the
gallery title will no longer show up.

Template types
None
No templates are used.
Simple templates 64
The easiest way to create templates.
Advanced templates 64
The most powerful, but also more complex way to create templates.

Tags
The following tags can be used in the templates:
Available tags ... 64

User files
If your custom design requires custom background images or stylesheet, then make sure you select
them as User Files 30 . This will make sure the files are automatically copied to the index page and
image pages folder and uploaded to the webserver with the Publish Files 54 feature.
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Simple HTML Templates
Simple templates are the most convenient way to create HTML templates
control, use the Advanced Templates option 64 .

63

. If you want even more

To create your own templates:
1. Open the HTML Templates window by selecting Edit menu > HTML Templates in the main
window.
2. Select the Simple templates customization option.
3. Check the "Use index page template" options.
4. Click the Create button to create a basic index page template.
5. Edit the template by clicking the Edit button. This will start your default HTML editor. You can set
the default HTML Editor in the Environment options window 70 .
6. After you saved the changes to the HTML template, recreate the gallery by clicking the All or
HTML button in the main window.
Template Tags ...

64

Example Simple HTML Templates ...

5.9.2

69

Advanced HTML Templates
Advanced HTML Templates are the most powerful way to create HTML Templates 63 . If you don't
need all these features, use the Simple Templates 64 option instead. Advanced templates allow you to
override default template tags. You could for example define your own navigation section.
You create a new advanced template set by clicking the Create button. Click the Edit button to find out
in which folder the template files are located.

5.9.3

HTML Template Tags

Index page tags
The following tags can be used in Index Page templates.
{indexpage.doctype}

Inserts the doctype at the beginning of
the index page file.

{indexpage.htmltitle}

Inserts gallery title on index pages.
This tag should be placed in the title
section of the template file (e.g.
<title>{indexpage.htmltitle}</title>).

{indexpage.head}

Contains all code that Arles needs to
put in the HTML <head> section. This
is generally meta tags, JavaScript and
custom HTML added to <head>
section.

{indexpage.body}

Inserts complete index page HTML
contents, including thumbnail table, the
navigation bars, custom HTML, gallery
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title, etc. This tag should placed be in
the <body> section of the template file.
This tag is defined in
"indexpage_body.html" file.
{indexpage.table}

Index thumbnail table.

{indexpage.thumbnail width=200 height=200}

Add this tag in your template to put a
thumbnail (and title if specified)
anywhere in your gallery. Width and
height and attributes can be set to
override the default thumbnail
maximum width and height. Eg:
{indexpage.thumbnail width=200
height=200}

{indexpage.thumbnail.url}

Inserts the url (link) to the image page.
This can be used in the HTML
Template of title area as follows:
<a
href="{indexpage.thumbnail.url}"
>Link text</a>

{indexpage.title}

Index page gallery title.

{indexpage.banner.top}

Index page top banner.

{indexpage.banner.bottom}

Index page bottom banner.

{indexpage.custom.top}

Custom HTML added to top of page.

{indexpage.custom.bottom}

Custom HTML added to bottom of
page.

{indexpage.align}

Index page alignment. Generally used
as follows: <div
align="{indexpage.align}">

{indexpage.table.cell.valign}

Index table vertical cell alignment.

{indexpage.table.cell.color}

Index table cell color.

Navigation tags
Note: Navigation tags only show up if the navigation elements are also selected in the Arles Navigation
Options window.
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{indexpage.navigation.top}

Index page top navigation. The
navigation section is defined in the
"indexpage_navigation.html" template
file.

{indexpage.navigation.bottom}

Index page bottom navigation. The
navigation section is defined in the
"indexpage_navigation.html" template
file.

{indexpage.navigation.home}

Home navigation item.
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{indexpage.navigation.home.url}

Link to Home.

{indexpage.navigation.up}

One level up navigation item. Used in
multi-folder processing.

{indexpage.navigation.up.url}

Link to one level up index page.

{indexpage.navigation.first}

First page navigation item.

{indexpage.navigation.first.url}

Link to first index page.

{indexpage.navigation.previous}

Previous page navigation item.

{indexpage.navigation.previous.url}

Link to previous index page.

{indexpage.navigation.next}

Next page navigation item.

{indexpage.navigation.next.url}

Link to next index page.

{indexpage.navigation.last}

Last page navigation item.

{indexpage.navigation.last.url}

Link to last index page.

{indexpage.navigation.quicklist}

Quicklist navigation item.

{indexpage.navigation.count}

"Index 1" navigation item.

{indexpage.navigation.count.unformatted}

Index page counter (e.g. "1") without
formatting.

{indexpage.navigation.total}

"Of 20" navigation item

{indexpage.navigation.total.unformatted}

Total index page count (e.g. "20")
without formatting.

{indexpage.navigation.bar}

Inserts crumbtrail navigation bar used
in multi-folder processing.

Special group comments can be used to trim the contents of the navigation section.
<!-- BeginNavigationElement -->
<!-- EndNavigationElement -->

Marks a single navigation element. If the element is
not selected, everything between these comments
will be removed.

<!-- BeginNavigationGroup -->
<!-- EndNavigationGroup -->

Marks a group of elements. If no navigation items are
selected in this group everything between these
comments will be removed.

<!-- BeginNavigationSubGroup -->
<!-- BeginNavigationSubGroup -->

Marks a subgroup of elements. If no navigation items
are selected in this group everything between these
comments will be removed. Subgroups can be used
inside groups.

<!-- BeginNavigationTop -->
<!-- EndNavigationTop -->

Marks the navigation section at the top of the page.
The complete section will be removed if no navigation
items are selected.

<!-- BeginNavigationBottom -->
<!-- BeginNavigationBottom -->

Marks the navigation section at the bottom of the
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page. The complete section will be removed if no
navigation items are selected.

Thumbnail tags
The following tags can only be used in the "indexpage_thumbnail_imageandtitle_*.html" template
files:
{indexpage.thumbnail.image}

Index page thumbnail image. This tag
can only be used in the
"indexpage_thumbnail_imageandtitle"
template files.

{indexpage.thumbnail.title}

Thumbnail title.

{indexpage.thumbnail.title.textalign}

Thumbnail title text alignment.

{indexpage.thumbnail.title.align}

Thumbnail title horizontal alignment.

{indexpage.thumbnail.title.valign}

Thumbnail title vertical alignment.

Image page tags
The following tags can be used in image page templates.

Digital Dutch

{imagepage.doctype}

Inserts the doctype at the beginning of
the index page file.

{imagepage.head}

Contains all code that Arles needs to
put in the HTML <head> section. This
is generally meta tags, JavaScript and
custom HTML added to <head>
section.

{imagepage.body}

Inserts complete image page HTML
contents. This includes the navigation
bars. This tag should placed be in the
"body" section of the template file.

{imagepage.htmltitle}

Inserts HTML title on image pages.
This tag should be placed in the title
section of the template file (e.g.
<title>{imagepage.htmltitle}</title>).

{imagepage.title}

Image page title.

{imagepage.imageandtitle}

Image and title.

{imagepage.banner.top}

Index page top banner.

{imagepage.banner.bottom}

Index page bottom banner.

{imagepage.custom.top}

Image page custom HTML added to
top of page.

{imagepage.custom.bottom}

Image page custom HTML added to
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bottom of page.
{imagepage.image}

Image.

{imagepage.navigation.top}

Image page top navigation section.

{imagepage.navigation.bottom}

Image page bottom navigation section.

{imagepage.navigation.slideshow.startstop}

Slideshow start/stop navigation item.

{imagepage.navigation.home}

Home navigation item.

{imagepage.navigation.home.url}

Link to home.

{imagepage.navigation.index}

Index page navigation item.

{imagepage.navigation.index.url}

Link to index page.

{imagepage.navigation.first}

First page navigation item.

{imagepage.navigation.first.url}

Link to first image page.

{imagepage.navigation.previous}

Previous page navigation item.

{imagepage.navigation.previous.url}

Link to previous image page.

{imagepage.navigation.next}

Next page navigation item.

{imagepage.navigation.next.url}

Link to next image page.

{imagepage.navigation.last}

Last page navigation item.

{imagepage.navigation.last.url}

Link to last image page.

{imagepage.navigation.quicklist}

Quicklist navigation item.

{imagepage.navigation.count}

"Image 2" navigation item.

{imagepage.navigation.count.unformatted}

Image index (e.g. "2") without any
formatting.

{imagepage.navigation.total}

"Of 20" navigation item.

{imagepage.navigation.total.unformatted}

Image total count (e.g. "20") without
any formatting.

{imagepage.navigation.bar}

Inserts crumbtrail navigation bar used
in multi-folder processing.

{imagepage.align}

Image page horizontal alignment.

{imagepage.title.align}

Image page title alignment.

{imagepage.title.valign}

Image page vertical title alignment.

{imagepage.title.textalign}

Image page text alignment.
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Other tags
Navigation cell spacing.

{navigation.option.spacing}

5.9.4

Simple HTML Template Example
This example shows what the most basic template looks like. You can create these templates by
clicking the Create button in the Template Window 63 .
Index page template file
{indexpage.doctype}
<html>
<head>
<title>{indexpage.htmltitle}</title>
{indexpage.head}
</head>
<body>
{indexpage.body}
</body>
</html>

Image pages template file
{imagepage.doctype}
<html>
<head>
<title>{imagepage.htmltitle}</title>
{imagepage.head}
</head>
<body>
{imagepage.body}
</body>
</html>

5.10

Options
In the Web Page Creator select the Tools menu > Options to display the Web Page Creator Options
window.
Go to the Arles Image Explorer

2

to set Image Explorer options

The tabs of the Web Page Creator Options window are:
General 70
Set general Arles Image Web Page Creator options.
HTML 70
Set HTML generation options.
File locations
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Specify folder locations.
Confirmations 72
Select which confirmation and warning dialogs you want to see.
Browsers 72
Set HTML browser options.
Other

73

5.10.1 General
Interface options
Show created gallery in browser after creating HTML
Select this options to automatically show newly created HTML pages in your default browser. Without
this option, you have to click the Show button on the toolbar to show the generated pages.
Reopen option windows on startup
Select to start Arles with all sub windows open that were open the last time that Arles was closed.
Set Source folder when browsing in the Arles Image Explorer
Select this option is you want the source folder to automatically change when you select another folder
in the Arles Image Explorer 2 .

Startup
Load default gallery style
Arles starts with the default gallery style as specified in the Default gallery style drop down box.
Open most recently used Arles file
Loads the most recently used Arles file when starting Arles. Recommended if you often work with the
same style files.

5.10.2 HTML
Options
Default HTML file extension
Default extension for all generated HTML files in new image galleries. The default file extension can be
either selected from the drop down list or typed directly in the edit box. The file extensions for the index
file and image files can be specified on the File Names tab 27 in the Advanced Files Options window
27 .
Convert line breaks to HTML breaks
In HTML code line breaks require the </br> tag. Select this option if you want line breaks in titles to
show up as line breaks in HTML pages. Arles will automatically add the </br> tag if this option is
selected.
Allow HTML code in titles
Select when you want to use HTML code in your titles. HTML code can be handy when you want to
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format the title. Say you want a bold line saying "Holiday" in bold and a second line saying "Spain
2006" below that. This can be achieved using HTML tags like this:
<b>Holiday</b><br />
Spain 2006

If this option is not selected characters that are not allowed in HTML will be encoded. For example, "<"
will be replaced with "&lt;" and "&" is replaced with "&amp;". If Western (Latin1) page encoding is
selected, non-standard Latin characters, like "é", are also converted. In this case the character "é" is
converted into "&eacute;". Custom HTML fields 40 are never encoded, because these fields can
contain raw HTML code that will not work if encoded.
Hide link to Arles web site for all galleries
By default the Arles links are set for each gallery on the Advanced Index Page Options 40 and
Advanced Image Page Options 47 windows. Select this option to always hide the links to the Arles
web site for all galleries.
This option can only be selected in the registered Arles version

2

.

HTML document encoding and type
Document encoding
In HTML pages different languages required different encodings. Generally, you don't want to change
these options if you use your language is based on the Latin alphabet, like English, Spanish or
German. Western (Latin1) is recommended for these languages.
Unicode (UTF-8) encoding works with any world language. However, some older webservers and
browsers may have a problem with Unicode encoded webpages. For maximum compatibility with older
webservers and browser use a language specific encoding, like Western (Latin1) instead.
Document type
The document type determines the HTML contents type. Use the drop down arrow to quickly select
HTML 4.01 transitional or XHTML transitional. You can also type any other coding yourself.
Encode URLs
When selected characters that are not allowed in URLs are encoded with their character number
equivalent. For example, spaces are replaced with "%20". It is recommended to always have this
option selected.
Use XHTML tag endings (e.g. />)
When using XHTML, tags without end tags, like <br>, have a forward slash before the tag end (e.g.
<br />). Select this option to use XHTML type tag endings.
Reset
Click the Reset button to reset the document encoding and type to the default that works for most web
pages.

5.10.3 File locations
File locations
Set the appropriate folders to specify the default locations where Arles looks for images.
Buttons images
Default folder for the button images. You can select button images for your navigation items
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Background images
Default folder for the background images. Background images are used for the HTML Design
window.

40

Banner images
Default folder for banners.
You might want to add your own button and background images to this folder to make Style 76
transfers between computers easier. If you load a style and Arles Image Web Page Creator can not
find the button or background images, it checks these folders.
The locations of thumbnails, images and navigation images are stored with the gallery settings and
can be specified in the Advanced File Locations window 27 .

5.10.4 Confirmations
Confirmations
Confirm before creating target folder
Check this option to be warned when Arles creates a new target folder.
Confirm before publishing to FTP server
Check this option to be warned when Arles publishes a gallery to your web server.
Warn if critical tags are missing in templates
When using HTML templates 63 , Arles needs several tags in the templates to be able to create the
gallery. You will receive a warning if Arles cannot find the tags it requires. In rare cases want to remove
these critical tags from the HTML templates anyway without Arles complaining about it. Unselect this
option to do so.
Recommended setting: Selected
Warn when saving transparent images
Arles can process images with transparency and save them as transparent PNG images. To correctly
view galleries with transparent PNG images Microsoft Internet Explorer 7 or better is required. Internet
Explorer 6 and older versions contain a bug preventing transparent PNG images from showing
properly. The transparent parts of the image will show up in a strange color on older IE versions. The
Opera and Firefox web browsers handle transparent PNG images just fine.
Confirm unselecting erroneous images
When Arles finds images that it cannot load because they contain errors, it will automatically unselect
them in the Arles Image Explorer to prevent the load error from appearing again. Select this dialog if
you want to be warned when this happens.
Show warning dialog on gallery creation errors
If an error occurs when generating a gallery Arles will show add the error message in the Progress
Window log area and popup a dialog. Unselect this option if you do not want to see the error dialogs.

5.10.5 Browsers
User defined browsers
Multiple browsers can be set to show generated galleries. Type the browser name on the left side and
select the browser full filename on the right. Use the drop-down menu of the Show button on the
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Toolbar to view a generated gallery in the specified browser.
To find the correct full filename for a browser, right-click the browser icon in the Windows explorer and
select Properties from the popup menu. The Target field shows the correct full filename. For Internet
Explorer on Windows XP this is by default:
C:\Program Files\Internet Explorer\iexplore.exe

Default browser
The default browser is used to show the generated gallery when the Show button in the Web Page
Creator window is clicked.

External HTML editor
This options allows you to specify the HTML editor you want to use when clicking the Edit button in the
HTML Templates Window 63 .

5.10.6 Other
File modified check
The overwrite thumbnails and images 26 option checks if files are need to be regenerated by
comparing the file modification time of original images with previously generated images. It is
recommended to select a 2 second tolerance when working with older FAT file systems.

Sounds
Select to play a sound when Arles is ready generating galleries or publishing.

Logging
Select to store all actions, warnings and error messages in a log file. The log file is located in the same
folder as the Arles.exe file. Old log entries are automatically purged when the file size grows over
50KB. When using Arles from the command line 77 actions and errors are always logged.
View log
Click the View log button to open the log file.

Debugging
Show extensive error messages
Select to receive extensive error information for debugging. This options should only be used if you
experience problems or when requested by Digital Dutch.

5.11

Other

5.11.1 Internet Explorer Security Warning
When showing the generated gallery on your local computer, Internet Explorer may show the following
warning:
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Internet Explorer disables by default all JavaScript in local HTML files. The good news is that the files
will work just fine once they are placed on your webserver. To prevent the security warnings from
showing when testing generated pages on your local computer.
Solution 1
Use the Firefox or Opera web browsers to test your galleries.
Solution 2
Tell Internet Explorer to allow scripting in local files.
· In Internet Explorer select the Tools menu > Internet Options.
· In the Internet Options window, select the Advanced tab.
· In the Security section select the Allow active content to run in files on My Computer option.
Solution 3 (not recommended)
Add what Microsoft calls Mark of the Web code to your web pages:
<!-- saved from url=(0014)about:internet -->

or
<!-- saved from url=(0016)www.yoursite.com -->

Note that the number between the brackets needs to be the length of the site string. You can do put
this in the HTML added to the <Head> 40 section area or add it to your Arles HTML template file 63 .
The problem with the Mark of the Web solution is that it disables linking to any other webpage that
does not contain the same mark. Solution 3 is only recommended when you are absolutely sure that
there are no links to other pages.

5.11.2 JPEG or PNG?
Arles saves generated images in a Internet compatible format. You can specify the default image file
format for thumbnails and images.

JPEG or PNG?
Select JPEG to create image galleries on the web with a small download size and maximum
compatibility. Select PNG if you want the best image quality.

Image information

JPEG

PNG

Bitmap
(for
comparis
on only)

Lossy

Lossless

Lossless
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Image quality

Good

Excellent

Excellent

Compression

Excellent

Medium

None

File size

Small

Medium

Large

Browser compatibility

Excellent

Good

None

JPEG is still the standard for showing images on the Internet. The main reason being that JPEG
produces the smallest files with good image quality. The main problem of JPEG is that some image
information is sacrificed (lossy compression) to achieve the small image file size. A nice feature of
JPEG is that the image quality factor 32 (and thus compression) can be set. Keep in mind that even
at 100% some image information is still lost.
PNG files are about 4 times larger than average JPEG files (though still much smaller than a bitmap
file), but they are lossless. Just like bitmap files you can modify and save them again and again without
losing any image information (lossless compression).
JPEG images are wider supported than PNG. All modern image editors and web browsers support
PNG, but if you want to make sure users with old web browsers can view your image galleries, use
JPEG.

5.11.3 Image Resize Methods
To resize images Arles uses advanced resample algorithms like Mitchell and Lanczos 3, which
produce superior quality thumbnails and images. You can set the image resize method for both
thumbnails 32 and images 34 .

Which resize method should I use?
For top quality images use either Mitchell or Lanczos 3. Lanczos 3 is the default and arguably
produces the best thumbnails of photographic images when used in combination with a sharpen filter
75 . The Mitchell filter generally shows a little less ringing artifacts than the Lanczos 3 filter, but the
thumbnails are also a bit less sharp. Some of the other filters are faster, but produce lower quality
images.
Mitchell is generally your best choice if you want to make your images larger (yes you can do that too).
Lanczos 3 is also recommended for graphic type images. It produces the sharpest results with the
least smoothing.
Tip
If your images look somewhat fuzzy make sure you select a sharpen filter

75

.

5.11.4 Image Filters
The following filters can be applied for thumbnails and other images

32

.

Sharpen filters
Sharpen
Makes your images look sharper,by increasing the contrast between adjacent pixels with significant
color contrasts, usually at the edges of objects. It lightens the light pixels and darkens the dark pixels.
Sharpen more
Sharpen filter with more intensity. Use this if the end result still looks slightly out of focus. Using this
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instead of sharpen can lead to artifacts on some images.
High pass
Extreme intense sharpen filter.

Blur filters
Blur
Smoothes transitions and decrease contrast by averaging the pixels next to hard edges of defined
lines and areas where there are significant color transitions. Apply the Blur or Soften filters to an image
to reduce graininess.
Soften
Applies a uniform blur to an image.

Edge filters
Edge enhance
Increases contrast along the edges in the image.
Find edges
Enhances the contrasts between light and dark in the image by darkening the image and then
highlighting the edges.
Laplace
Laplace edge detection filter

Other
Emboss
Converts the image into a bas-relief. Emboss causes the foreground to appear raised from the
background by suppressing color and tracing edges in black.

5.11.5 Style Files
Styles are an easy way to share layouts between image galleries. A style contains all gallery settings
from page colors to thumbnail sizes.

Saving and loading
To save the current style:
· In the Arles Image Web Page Creator

25

window select the File menu > Save style.

To load a style:
· In the Arles Image Web Page Creator

25

window select the File menu > Load style .

You can also load a style from a standard Arles file (*.arl).
Button and background images
The style does contain all gallery settings but not the button and background images. To use a style on
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another computer you have copy any banner image files and template files specified in the style. If a
button or background image can not be found, Arles Image Web Page Creator will look in the default
button and background folders 71 to check if they exist there. This is the reason why the default button
and background folders are the best place to store your button and background images.

5.11.6 Command Line Run Options
In the Run Options window you can specify command line scripts to be run before or after generating
a gallery. To open the Run Options window, in the main window select the Edit menu > Run Options.

Command to run before generating gallery
Specify the command or script you want to run before generating a gallery. Arles will wait for the
command or script to finish before proceeding.
Insert tag
Click the Insert Tag button to insert a folder title tag
with the correct content for each gallery.

53

. Arles will automatically replace these tags

Command to run after generating gallery
Specify the command or script you want to run after a gallery has been generated.

Examples
python c:\scripts\your_script.py
Runs the your_script.py Python script file.
python c:\scripts\your_script.py "<SourceFolder>" "<TargetFolder>"
Run a python script with the source and target folders as arguments.

Options
Save run options in gallery file
Select if you want the command line settings to be stored in the gallery file for each gallery. Unselect if
you want to use the specified command for all galleries.
Run minimized
Makes the command run in a minimized window, which prevents the window from showing,
disappearing and grabbing the focus every time a command is run. This is especially helpful during
multi-folder processing where commands may be run many times.

5.11.7 Command Line Processing
To set up command line control, first open Arles and set all options like you want them. If everything
works like you want, select the File menu > Save. Then call Arles from the command line with the
settings file you just saved.
All actions, warnings and errors are stored in the arles.log
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ASCII. So you can edit them using a script language or ASCII text editor.

Synopsis
arles.exe [options] [settings filename]

Options
-a, --all
Process all actions. Generate thumbnails, modify images and create HTML pages. Equivalent with
clicking the All button in the toolbar.
-d, --dontclose
Don't close Arles after command line processing has finished. This option is ignored if the -n or --nogui
option is selected.
-i, --images
Modify images. Equivalent with clicking the Images button in the toolbar.
-h, --html
Create gallery HTML pages. Equivalent with clicking the HTML button in the toolbar.
-l, --log
Show Arles log file after the command line processing has finished.
-m, --multifolder
Use multi-folder processing. All other options will now refer to the multi-folder processing window.
-n, --nogui
Don't show the Arles GUI (Graphical User Interface). Arles will run hidden in the background.
-p, --publish
Publish the generated gallery to the web server. Equivalent to clicking the Find & Check and Publish
buttons in the Publish Files window.
-source FOLDER
Source folder for gallery creation.
-t, --thumbnails
Generate thumbnails. Equivalent with clicking the Thumbnails button in the toolbar.
-target FOLDER
Target folder for gallery creation.
-w, --webpagecreator
Startup with Web Page Creator window

Examples
"C:\Program Files\Digital Dutch\Arles Image Web Page Creator\arles.exe" -a "C:\gallery.arl"
Create an image gallery using the gallery.arl options file.
"C:\Program Files\Digital Dutch\Arles Image Web Page Creator\arles.exe" -a -m -p
"C:\gallery.arl"
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Create multi-folder galleries using the gallery.arl options file and publish the results to your web server.
"C:\Program Files\Digital Dutch\Arles Image Web Page Creator\arles.exe" -a -source
"C:\Images\Mexico" -target "C:\Website\Images\Mexico" "C:\gallery.arl"
Create an image gallery using the gallery.arl options file, "C:\Images\Mexico" as source folder and
"C:\Website\Images\Mexico" as target folder.

5.12

Multi-folder Processing
To open the Multi-folder processing window, select in the main window the Tools menu >
Multi-folder processing.

What is multi-folder processing?
The multi-folder processing window allows you to create galleries of multiple directories. Say, your
images are organized as follows:
C:\Images
C:\Images\Holiday
C:\Images\Holiday\France
C:\Images\Holiday\Mexico
C:\Images\Family
C:\Images\Family\John
C:\Images\Family\Ann

Arles allows you to select the root folder C:\Images and create image galleries for each folder.

Subcategories
Arles will create links to subcategories (subfolders with images) if you switch on the Add
subcategories option on the main window File Locations tab 26 .

To process multiple folders
Step 1
Select the Root folder. This is the folder in which all your images and subfolders with images are
located.
Step 2
Set the target folder type:
Same as source folder
Arles will put all generated files in the same folder as the images. With this setting your original images
will get mixed with files generated by Arles. This can easily become a bit messy, which is the reason
why it is not recommended.
Subfolder
All generated files will be put in a subfolder of the source folder. For example, if you specified "HTML"
as subfolder and your images are in C:\Images, the created files will be put in C:\Images\HTML.
Other
All gallery files will be put in the defined target folder. The target folder will have the same directory
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structure as the root source folder. To keep the generated files separated from the original images, it
is recommended to specify a target folder outside the root folder.
Step 3
Click the Find folders button to search for folders with images. The treeview will now also show the
target folder for each source folder.
Step 4
Select the checkboxes for the folders you want to be processed.
Step 5
Click the All, Thumbnails, Images or HTML button to start the processing. It works the same as in the
main window.
The grid shows the found source folders the number of image in each folder and the destination
folders.

To view the results
Select a folder in the grid and click the Show button to show the results.

Folder Options
You can select a Default image or Custom style for each folder on the Folder info
Arles Image Explorer 2 .

6

panel in the

Tip
Action commands in the popup menu will only process the selected folders. So, if you want to recreate
HTML for only one folder, right click it and select Create HTML from the popup menu.

6

FAQ

6.1

How to add titles to my images?
You can add titles to your images in the Arles Image Explorer.
See: Editing image titles...

5

External link
· Add titles to your images tutorial on digitaldutch.com website.

6.2

How to create galleries of web pages?
With Arles you can create image galleries from website links or from local HTML files.

External link
·

Creating galleries of websites tutorial on digitaldutch.com website.
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How to create multi-folder galleries?
Say your images are organized as follows:
C:\images\holiday
C:\images\holiday\spain
C:\images\holiday\greece
C:\images\friends\johns_birthday
C:\images\friends\cathy

and you want to create gallery that includes all these categories with the C:\images folder linking to
the subgalleries.
· In the Image Web Page Creator window select the Files tab and select the Add Subcategories
option.
· In the Image Web Page Creator window select the Tools menu > Multi-folder processing.
· In the Multi-folder processing window select your top folder (e.g. C:\images) as Root folder.
· Set the Target folder type to Other folder. You can select other target folder types, but this is
discouraged, because the files generated by Arles will mix with your original images making things
less organized.
· In the Multi-folder processing window select a target folder location. This is where all files generated
by Arles will be put.
· Click the Find Folders button on the Toolbar to find all subfolders with images.
· If you are satisfied with the results click the All button.

6.4

How to create a gallery with movies?
There several ways to handle movie files in the generated galleries.

Embed movies
To embed movies in the image pages using the Window Media Player control:
·
·
·
·
.

In the Web Page Creator window 25 select the Image Pages tab 46 and click the Advanced button.
In the Advanced Image Pages Options 28 window select the Movies tab 49 .
Select the Embed movies option.
Recreate your gallery by clicking the All button in the Web Page Creator window.

Link the thumbnails directly to the movie file.
To link thumbnails directly to the movies:
·
·
·
·

In the Web Page Creator window select the Index Page tab 35 and click the Advanced button.
In the Advanced Index Page Options 44 window select the Thumbnail Links tab.
Select the Link non-images, like movies, always to the original files option.
Recreate your gallery by clicking the All button in the Web Page Creator window.

Link the image-page image to the movie file
You can also select to show the movie poster frame on the image page and link this image to the
movie file. This can be done in the following way:
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·
·
·
·

6.5

In the Web Page Creator window 25 select the Image Pages tab 46 and click the Advanced button.
In the Advanced Image Pages Options 28 window select the Image Links tab.
Select the Link non-images , like movies, always to the original files option.
Recreate your gallery by clicking the All button in the Web Page Creator window.

Copy or move my images files without losing image titles?
Don't use the Windows Explorer to move your images if you want to keep image titles. Use the Arles
Image Explorer 2 instead, to keep title information. You can copy images by dragging and dropping
them with your mouse or by using copy (Ctrl+C) and paste (Ctrl+V). To open the Arles Image Explorer
click the Browse button in Arles Image Web Page Creator window.

IPTC
Another option is to use the IPTC information window
right into the image files.

6.6

25

, which allows you to store IPTC information

Remove the "Generated With Arles Image Web Page Creator"
links?
The links to the Arles website can be only be disabled in registered versions
Page Creator.

2

of Arles Image Web

To disable the Arles links for the current gallery:
· Open the Advanced Index Page Properties window by clicking the Advanced button on the Index
Page tab.
· Deselect "Add link to Arles Web Site".
· Do the same in the Advanced Image Pages Properties window by clicking the Advanced button on
the Image Pages tab.
To disable the links for all galleries:
· In the main window select Tools menu > Environment Options.
· In the Environment Options window, select the HTML tab.
· Select "Hide link to Arles web site for All galleries".
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getting started 1
grayscale 57

-HHow to
Add titles to your images

80

83

84
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How to
Create galleries of web pages
HTML
custom 40
page properties 40
HTML tag definitions 64
HTML templates 63
advanced 64
simple 64
tag definitions 64

-IImage Explorer 2
keyboard shortcuts 22
options 14
image overlay effect 62
image pages
advanced options 47
banners 40
colors 40
custom HTML 40
options 46
image title tags 53
image viewer
keyboard shortcuts 23
images
advanced options 34
borders 61
database 18
disable right-clicking 41
drag and drop 6
effects 57
email 9
EXIF image information 10
file format 74
filters 75
grayscale 57
Image Explorer 2
image overlay effect 62
information 5
IPTC image information 10
JPEG 74
JPEG comment 12
logo 60
masks 62
options 33
PNG 74

80

resampling 75
resize 33, 75
rotate 4
select 5
sepia 57
slideshow 46
sort 4
text label 33
text labels 59
thumbnails 31
titles 5
view 3
watermark (logo) 60
watermark (text) 59
index page
advanced options 40
banners 40
borders 42
colors 40
custom HTML 40
options 35
table cell options 43
thumbnail layout options 43
Internet Explorer security warning
IPTC image information 10
IPTC window
keyboard shortcuts 25

73

-JJPEG 74
JPEG comment 12
jpeg comment window
keyboard shortcuts

25

-Kkeyboard shortcuts
Image Explorer 22
image viewer 23
IPTC image information window
jpeg comment window 25

25

-Lload
style

76
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Index

location
database
logging 73
logo 60

movie 13
print services 46
protection
images 48
thumbnails 41
publish
files 54
location options 56
options 57

21

-Mmasks 62
Movies
create gallery with movies
play 13
select poster frame 13
view 13
multi-folder processing 79

49

37

-Ooptions
advanced files 27
advanced image 34
advanced image pages 47
advanced index page 35, 40
advanced thumbnail 32
advanced title 51
email 17
environment 69
gallery style 36
image and thumbnail effects 57
Image Explorer 14
image pages 46
images 33
index page 35
slideshow 46
thumbnails 31
titles 50
ordering information 2

-Pplay movies 13
PNG 74
popups 45
poster Frame
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quick start

1

-R-

-Nnavigation

-Q-

register 2
rename files 8
resample
images 75
resize
images 33, 47
restore database 19
rotate images 4
run options 77

-Ssave
style 76
security warning
Internet Explorer 73
sepia 57
server
upload 54
shortcuts
Image Explorer 22
image viewer 23
IPTC image information window
jpeg comment window 25
simple HTML templates 64
slideshow 46
sort images 4
source folder 26
style files 76
subcategories 79
subfolders 28

25

85
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-T-

-V-

tags
HTML Template 64
title tags (folder) 53
title tags (images) 53
target folder 26
templates
example 69
HTML 63
using 63
text label
images 33
text labels
images 59
thumbnail
HTML border 43
layout options 43
thumbnail table options 42
thumbnails
advanced options 32
borders 61
crop to fit 33
effects 57
grayscale 57
image overlay effect 62
links 44
logo 60
masks 62
options 31
sepia 57
text labels 59
watermark (logo) 60
watermark (text) 59
title
folder 6
title options 50
titles
advanced options 51
image 5

view images

3

-Wwarning
Internet Explorer
watermark
logo 60
text 59

73

-Uupload 54
user files 30
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